So I have just installed latex-suite using the default version of vim that ships with OSX 10.6. The problem I'm having is that \cite completion is not working properly. This is what happens:

  1. Begin citation by typing \cite{author
  2. Press Fn F9 to bring up matches
  3. Select match
  4. Press Enter. Instead of the citation being completed, I'm back at an empty \cite. Latex-suite is not completing the citation for me.

I've tried this with both iTerm and the OSX terminal. Any pointers as to what is going wrong?

  • I have the same problem, can someone give us a fix please ? all other functionalities of vim latex are also working fine.
    – user4579
    Apr 5 '11 at 13:59
  • This is a software issue and not a TeX one. You might get betters answers (or any answers for that matter) if you ask it in a software related site. I can migrate it to one for you if you want. Apr 5 '11 at 14:43
  • 4
    Yes, it is a comment on the vim-latex plugin suite. However, I don't see how this is off topic. The FAQ on this site explicitly says that "(La)TeX related software and tools like BibTeX, LyX, LaTeX editors, viewers, and converters" questions are allowed.
    – MichaelM
    Apr 21 '11 at 5:42
  • 1
    I agree with @MichaelM. I'm having the same problem, and this is a useful question. If questions like these are considered off-topic by the community as a whole, then the FAQ should be updated to reflect that.
    – Will
    Oct 31 '12 at 20:54
  • 1
    Since the question is closed I cannot add an answer, but for me this function stopt working after installing another Python version using brew. Unlinking that Python version (thereby restoring the original Python as the default) solved the problem for me. Another way that solved it was by not using Python at all (add let g:Tex_UsePython=0 to your .vimrc). Apr 6 '16 at 10:06

Browse other questions tagged or ask your own question.