23

For collaboration purposes I am using the draft mode in my LaTeX manuscript to show todo-notes, remarks and so on. By switching to final mode all of these additions become unvisible.

However, I'd love to switch on the final mode of the graphics/x package to see the actual pictures but \documentclass being still in draft mode. I get an error about clashing options when I add

\usepackage[final]{graphicx}

My first guess was that the \documentclass already sets the option for the graphics/x package. Following doesn't help either

\PassOptionsToPackage{final}{graphicx}
\documentclass[twoside,onecolumn,draft]{rsauthor}
5
  • Is there a place where rsauthor.cls can be examined?
    – egreg
    Commented Oct 1, 2012 at 16:04
  • @egreg: It is freely available from the journal website: Proceedings of the Royal Society A - rsauthor.cls
    – Hotschke
    Commented Oct 1, 2012 at 16:18
  • Suggestion: Add a tag for "trackchanges" (or mention it in the question so that searches find this better)
    – TomOnTime
    Commented Aug 8, 2013 at 20:17
  • Suggestion: The title would be more readable as: "In graphics/graphicx, how to show actual pictures despite draft mode"
    – TomOnTime
    Commented Aug 8, 2013 at 20:18
  • I am happy with your title suggestion. I've changed it.
    – Hotschke
    Commented Aug 9, 2013 at 6:40

2 Answers 2

29
\RequirePackage[final]{graphicx}
\documentclass[twoside,onecolumn,draft]{rsauthor}

probably works

Also (without doing that) you can flip the draft flag in the preamble (after \usepackage{graphicx}) as

\setkeys{Gin}{draft=false}
7
  • no this doesn't help. Thanks for you help anyway.
    – Hotschke
    Commented Oct 1, 2012 at 16:19
  • odd. what error does it give (I didn't have rsauthor class to test) Commented Oct 1, 2012 at 16:29
  • I tried with the rsauthor class and both methods work. The second seems preferable.
    – egreg
    Commented Oct 1, 2012 at 16:31
  • @David Carlisle: the second suggestion with \setkeys works. Wow, thank you very much. I am always impressed by the fast and perfect help on tex.sx.com.
    – Hotschke
    Commented Oct 1, 2012 at 16:47
  • 2
    The RequirePackage technique worked for me but I had to put that line before the \documentclass line.
    – TomOnTime
    Commented Aug 8, 2013 at 20:15
0

There might be a conflicting package that loads graphics. For example if you load grffile because it says so in the matlab2tikz documentation, make sure to load it before graphicx like so:

\usepackage[final]{grffile}    
\usepackage[final]{graphicx}

Or just leave it, it seems to work ether way. I did not need any other options magic. I only cleaned my header file from packages that load graphics.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .