I freshly installed 'basic' version of TeX Live 2012 (not full, only basic version).

I have following line in my code: \usepackage[T1]{fontenc}

I get following error:

/usr/local/texlive/2012/texmf-dist/tex/latex/base/fontenc.sty:100: Font T1/cmr/
m/n/10=ecrm1000 at 10.0pt not loadable: Metric (TFM) file not found.
<to be read again> 
l.100 \fontencoding\encodingdefault\selectfont

/usr/local/texlive/2012/texmf-dist/tex/latex/base/fontenc.sty:100:  ==> Fatal error occurred, no output PDF file produced!

I understand that some packages are missing, however I do not know which ones.

Also, solution to this problem on most of the earlier posts is to install ubuntu latex recommended package, however please note that I am not using LaTeX from Ubuntu's software center (which is old TeX Live 2009) but rather have manually installed basic version of TeX Live 2012 as per instructions here: http://www.tug.org/texlive/quickinstall.html

Please let me know how do I solve this issue (I don't want to install complete version of TeX Live 2012, only those packages necessary to run this piece of code).

  • 6
    Do you have the cm-super package installed?
    – doncherry
    Commented Oct 3, 2012 at 18:02
  • 11
    You should do sudo tlmgr install ec and sudo tlmgr install cm-super. But the best thing you can do is to install the full version or you'll be always confronting with missing packages.
    – egreg
    Commented Oct 3, 2012 at 22:26
  • @egreg: Thanks, your answer solved my problem. Commented Oct 4, 2012 at 2:23
  • 1
    At least in R/RStudio, you can install the tinytext package, which automatically installs missing dependencies: if (!require('tinytex')) install.packages('tinytex'); library('tinytex') And then: tinytex::install_tinytex()
    – Gorka
    Commented Jul 5, 2019 at 15:33

6 Answers 6


In this case, the missing file is ecrm1000.tfm according to the error message. To know which package it belongs to, you can use the command tlmgr search --file ecrm1000.tfm --global which finds it in package ec. So you have to install it with tlmgr install ec.

Then you may have other errors, other files to look up and other packages to install. Since the process may be cumbersome, you may want to install at least collection-latexrecommended and collection-fontsrecommended if you really don't want a full install.

An alternative would be to use the texliveonfly http://ctan.org/pkg/texliveonfly package which installs missing packages on the fly (see its documentation).

  • 11
    I had to add --global switch to find the file because otherwise the search appears to be only in the local installation: tlmgr search --file ecrm1000.tfm --global Commented Oct 16, 2014 at 18:16
  • 1
    tlmgr install collection-latexrecommended was a lifesaver for document class leaflet Commented Jan 22, 2020 at 21:38

I just installed the recommended fonts and it worked for me. =) The command for a Debian based Linux distribution (including Ubuntu and Mint):

sudo apt-get install texlive-fonts-recommended
  • It's working well :) Commented Oct 10, 2015 at 22:04
  • This is much more straight-forward solution for the problem than the other ad-hoc fix. It worked for me.
    – Yu Shen
    Commented Oct 25, 2016 at 7:21
  • In tex live this is collection-fontsrecommended.
    – Loren
    Commented Oct 27, 2016 at 15:49
  • 1
    I used sudo apt-get install texlive-fonts-recommends --no-install-recommends which reduced the size to only around 5 MB
    – Anwar
    Commented Mar 15, 2017 at 21:05
  • This solution works and doesn't require me to manually install seventeen different packages. Thank you. Commented Nov 16, 2018 at 1:42

In case you are on Fedora:

sudo dnf install texlive-collection-fontsrecommended.noarch
  • Works for OpenSUSE as well (as: sudo zypper install texlive-collection-fontsrecommended).
    – jciloa
    Commented Dec 13, 2020 at 15:47

On macOS / MacTeX install collection-fontsrecommended in the TeX Live Utility or tlmgr install collection-fontsrecommended from the command line.


I had multiple errors for several fonts with the textgreek package (Corrupted NFSS tables) and with XeTeX or better hyperref (Font \XeTeXLink@font=pzdr at 0.00002pt not loadable).

Edit: I found out (in this post) and by running tlmgr info pzdr that the error caused by the hyperref package can be fixed with the zapfding package because there is a pzdr.afm and a pzdr.tfm in the zapfding package. After installing zapfding everyting was working. The cbfonts like I mention below is not needed for me anymore.

Maybe cbfonts was needed for the other errors. I was able to fix the mentioned error Font \XeTeXLink@font=pzdr at 0.00002pt not loadable by using only zapfding. I cannot say something about the other "multiple errors for several fonts" anymore because I am working on a different TeX setup now. I am leaving the original answer below in case that the other errors were really caused by textgreek.

Original Post

I tried to load the fonts like @mpg describes it but some errors were still present. For some fonts I didn't even get a result when I run tlmgr search --file <name> --global (e.g. LGRcmr.fd or some others).

I ended up with installing the huge cbfonts via tlmgr (tlmgr install cbfonts) like of @Ulrike Fischer suggested in this answer. This works now for me.


In archlinux the package name is texlive-fontsrecommended

Installing it resolved my issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .