I ran into a very strange problem recently: I'm administrating Mandriva Linux in a networked setup where users authenticate via NIS. We noticed that pdflatex simply stalls with no error messages and output. All we get is the following:

    This is pdfTeX, Version 3.1415926-2.3-1.40.12 (TeX Live 2011/Mandriva)  
    restricted \write18 enabled.  

It doesn't accept any commands or produce any output that we can see. We get the same behavior if we try running it on a file, as in pdflatex <filename>
Using a local user (as opposed to an NIS user) account, I was able to compile LaTeX files with no problem, so this seems related to NIS somehow. The weird thing is, we have one NIS user who doesn't face this problem and can compile LaTeX files normally.
Has anybody seen this before? Are there known solutions/workarounds? Is there a way for me to investigate further to help you answer this question?

EDIT: My answer below is based on Martin Schröder's suggestion.

  • 4
    Run it with strace; it will show you where it hangs. – Martin Schröder Oct 4 '12 at 12:51
  • 1
    @JosephR.: You should be able to edit your question and include your findings. – Martin Schröder Oct 4 '12 at 15:50
  • 4
    Presumably this is somehow related to the search syntax in the TeX search libraries. A TEXINPUTS segment of /home/david/ would just look in that directory, but a TEXINPUTS segment /home/david// specifies that directory and all subdirectories should be recursively searched for file input. – David Carlisle Oct 4 '12 at 16:16
  • 1
    @JosephR. Your real question does not match the title now. I suggest you add your solution to the first question as an answer here and move your second question into a separate posting with a proper title (and delete it here). – Stephan Lehmke Dec 2 '12 at 0:11
  • 1
    @StephanLehmke Done. Will re-post the second question when I have time. – Joseph R. Dec 2 '12 at 13:20

Based on Martin Schröder's suggestion, I ran pdflatex through strace and I could pinpoint the problem: the problem was an extra slash in the home directories of users (e.g. <root_dir>//<user_name>).

For some reason, this caused LaTeX to search the whole of <root_dir> for its binaries, which obviously takes ages. A simple edit of /etc/passwd to remove the extra / and a re-hash of the NIS domain via

cd /var/yp && make

did the trick.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.