I have been trying to solve a 4x4 matrix and have done a hell a lot of writing. Now I am near the end and I am not getting the requested output out of the LaTeX compiler.

When I write for example:

R^{-1} = \frac{1}{\left|R\right|} \rm{adj}(R) = \alpha

the last symbol isn't shown as "alpha" but rather as a very weird symbol ff like I show in the picture below:

enter image description here

I get the same weird symbol for any symbol that I put in place of \alpha or even after it. From this point on all of my symbols are typeset as ff.

If I put same source code in my other new document all of my symbols again render as they were supposed to.

Q1: Have I ran out of memory?

Q2: How can I fix this?


You shouldn't be getting ff instead of \alpha. But your input has a bad error anyway: \rm is not a command with an argument, but rather a declaration that extends its influence until the group in which it's been issued ends, in this case up to \end{equation}.

The command \rm must not be used. Forget it, together with \it, \bf and \tt. They are obsolete and, as in your case, can be misunderstood by users.

In place of them use \textrm, \textit, \texttt and the others that you find in any user guide. In math there are \mathrm and some similar commands, but for operator names there's a better way: say


in your preamble and then your formula can be input as

R^{-1} = \frac{1}{\lvert R\rvert} \adj(R) = \alpha

The minipage you use is not needed and probably makes vertical spacing awkward. Note also \lvert and \rvert instead of \left| and `\right|.

| improve this answer | |
  • Ty your anwser solved my problem. Why is command \rm even there if i cannot use it? It didn't ruin my other equations... – 71GA Oct 4 '12 at 20:24
  • 2
    @71GA The command is still needed for backward compatibility, as older document may have it. Never use it yourself. – egreg Oct 4 '12 at 20:25
  • 1
    @71GA -- egreg is right; you shouldn't use the old 2-letter font commands. but if you must use it, then use it as {/rm ...}. this is what egreg meant when he said your input had an error. – barbara beeton Oct 4 '12 at 22:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.