June 2014 update: on the basis of this page and the question here I have written an installer for the MathTime fonts that should work with Unix systems running TeX Live. The installer page is on my website. My script has been successfully tested on Ubuntu 14.04 w/ TeX Live 2013, and a two year old MacBook Air running OS X w/ TeX Live 2012.

Recently I've been trying to install the MathTime Professional 2 font (free Lite version). I'm using TeX Live on Ubuntu 12.04.

I downloaded the files and copied them over to the folder /usr/share/texmf-texlive/. (The instructions suggested putting them in /usr/share/texmf/, but this didn't work for me.) After umpteen runs of texhash, updmap and updmap-sys, the pdflatex command can now find mtpro2.map. However now when I run pdflatex on a simple file

\usepackage[scaled=0.92]{helvet}    % set Helvetica as the sans-serif font
\renewcommand{\rmdefault}{ptm}      % set Times as the default text font
This is a test secton

I get the following error

(./LaTeX Article MTPro2Lite.aux) [1{/var/lib/texmf/fonts/map/pdftex/updmap/pdft
ex.map}] (./LaTeX Article MTPro2Lite.aux)
kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 1+0/600 --dpi 600 mt2mit
mktexpk: don't know how to create bitmap font for mt2mit.
kpathsea: Appending font creation commands to missfont.log.
!pdfTeX error: pdflatex (file mt2mit): Font mt2mit at 600 not found
 ==> Fatal error occurred, no output PDF file produced!

I've been Googling for about an hour trying to a find a solution, but I've found nothing. Does anyone have any advice on how I might proceed?

I'm a complete n00b when it comes to installing extras for LaTeX; sorry if this question is inappropriate.

Edit: running sudo updmap-sys --enable Map mtpro2.map outputs:

updmap: This is updmap, version $Id: updmap 14402 2009-07-23 17:09:15Z karl $
updmap: using transcript file `/var/lib/texmf/web2c/updmap.log'
updmap: initial config file is `/var/lib/texmf/web2c/updmap.cfg'
  • 3
    The error means that the updmap-sys run has not made what it should. You should not run updmap; first try removing the /home/james/.texmf-var/fonts/map/pdftex/updmap/pdftex.map file (the one created by updmap).
    – egreg
    Commented Oct 7, 2012 at 10:52
  • Thanks for the comment. I've deleted the .texmf-var directory but I'm still getting the same error. The file mt2mit.tfm is in the proper place in the texmf directory, and more runs of updmap-sys and texhash haven't done anything. Commented Oct 7, 2012 at 16:15
  • Did you run sudo updmap-sys --enable Map mtpro2.map?
    – egreg
    Commented Oct 7, 2012 at 16:31
  • Yes. Was just about to say: should I be worried that the command the updmap-sys --enable command only outputs 3 lines? It doesn't, for instance, run the updmap-sys command afterwards to refresh all the files. On the other hand, when I run updmap-sys --disable it subsequently executes updmap-sys. Commented Oct 7, 2012 at 16:34
  • 1
    Good to know. :-) Maybe you can clarify it on your Web page.
    – egreg
    Commented Jun 2, 2014 at 18:23

1 Answer 1


It seems that some problems have accumulated. As a last resort I'd try editing by hand the updmap.cfg file: with your favorite editor open the file, for instance with

sudo vim $(kpsewhich updmap.cfg)

and add at the end the line

Map mtpro2.map

Then run

sudo updmap-sys

and the system should be able to find the fonts.

  • 1
    This worked! @egreg was kind enough to offer his time on chat to fix the problem (we were on chat for nearly an hour). I am very, very grateful. Thank you egreg! Commented Oct 7, 2012 at 21:33
  • 1
    @JamesFennell Happy to have been able to help.
    – egreg
    Commented Oct 7, 2012 at 21:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .