SOLVED: I don't know why, but I throwed one abbreviation out of the document. Then I compiled and it worked. After that I copied it back again and it still worked. And since I did that I had no further problems. Strange.

First, I have to say I'm a beginner in TeX. Im currently writing my master thesis with Texmaker and MiKTeX 2.9 (pdftex) under Windows 7.

I actually wrote 70 pages without any problems. In my thesis I use the nomenclature package for the abbreviation index.

Now, since a few days I've been getting the following error message(s):

! LaTeX Error: Lonely \item--perhaps a missing list environment.


! Extra \endgroup.

I get the "lonely item" message for a multiple abbreviation in the index.

I'm trying to comment out some chapters and nomenclature uses. The problem is that it is not reproducible. Sometimes I can compile the document when I comment out this chapter and the next time compiling files again and then it doesn't compile at all.

I searched Google, but there's no solution for me. I haven't multiple abbreviations in the index. I tried to compile it under Linux and with TeX Live under Windows and Linux. Same errors.

Abbreviation index code in the main file:




When I comment out the \printnomenclature command it works, but there is no index in the document.

In my chapter .tex files I use

\abk[PIN]{PIN}{Personal Identification Number}

I also checked the temporary file where MakeIndex generates the abbreviation index. But there are no syntax errors. The only idea left I have that there is a problem when the abbreviation index is longer then one page.

Examples of the usage of the \abk-command:

\item \textbf{Linear Threshold Unit}\index{LTU}\abk[LTU]{LTU}{Linear Threshold Unit} ~\\
following text


Sie präsentieren die Resultate einer Analyse von GUI-based Intrusion Detection (GUIID)\abk[GUIID]{GUIID}{GUI-based Intrusion Detection} Systemen.

Example from the .nls-File (XOR is throwing an lonely item error):

\item [{XaaS}]\begingroup Everything as a Service\nomeqref {0}
\item [{XOR}]\begingroup eXclusive OR\nomeqref {0}\nompageref{43}

After deleting all \abk from the whole document, so there are no(!) abbreviations in it, there are still two errors:

! LaTeX Error: \begin{document} ended by \end{thenomenclature}. 


 ! Extra  \endgroup."

closed as too localized by egreg, lockstep, Stefan Kottwitz Oct 9 '12 at 14:00

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    My feeling is towards a bad \abk command, in the sense that one of its arguments contains a "fragile" command. Can you show, adding them to your question, the \abk commands in the offending chapter? – egreg Oct 8 '12 at 12:59
  • 1
    I forgot! Welcome to TeX.SX! – egreg Oct 8 '12 at 13:05
  • The problem is there is no "one" offending chapter. Sometimes it compiles and sometimes it doesn't, when I comment a random chapter and then it doesn't compile when I comment out ALL chapters. It's just so frustrating. Thanks :)! P.S.: I checked all my \abk commands and they're all in the same way. I wrote them just after the first usage of an abbreviation in the text. – pr177 Oct 8 '12 at 13:08
  • Please, add a self contained example; it needn't be long, just to give an idea of what you're doing in the document body. – egreg Oct 8 '12 at 13:19
  • I added examples in the question – pr177 Oct 8 '12 at 13:25