20

I'm using: biblatex 1.7.1; biber (0.9.6 I guess) and working on LyX on Kubuntu 12.04. For example, I'm setting in my .bbx file the value to 6:

\ExecuteBibliographyOptions
  {
    maxbibnames = 6
}

But in the reference list the references aren't truncated after 6 names as I would expect but rather displays only 1 name + et al. (only for entries with more than 6 authors, of course). But if I set it to say maxbibnames =99 then I get the full list of authors. The style I'm basing on calls for authoryear.bbx which truncates itself to the first name + et al. if there are more than 6 authors.

Why is that?

  • 4
    I believe you want maxbibnames=6, minbibnames=6, but I'm not 100% sure (I don't use BibLaTeX at all). – yo' Oct 10 '12 at 23:10
28

tohecz is right, you need to set minbibnames=6 as well. Here is an excerpt from the documentation (section 3.1.2.1):

maxnames=<integer> default: 3
A threshold affecting all lists of names (author, editor, etc.). If a list exceeds this threshold, i. e., if it holds more than <integer> names, it is automatically truncated according to the setting of the minnames option. maxnames is the master option which sets both maxbibnames and maxcitenames.

minnames=<integer> default: 1
A limit affecting all lists of names (author, editor, etc.). If a list holds more than maxnames names, it is automatically truncated to minnames names. The minnames value must be smaller than or equal to maxnames. minnames is the master option which sets both minbibnames and mincitenames.

maxbibnames=<integer> default: maxnames
Similar to maxnames but affects only the bibliography.

minbibnames=<integer> default: minnames
Similar to minnames but affects only the bibliography.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.