In this answer, I produced a new tfm file for the beamer standard math font. What is the Right Way to make the new font available to the TeX system? With texlive I tried

updmap-sys --enable Map=cmssmi.map

but this gave the following error message.

updmap: This is updmap, version $Id: updmap 14402 2009-07-23 17:09:15Z karl $
updmap: no permissions for writing /usr/local/texlive/2009/texmf-var/web2c/updmap.log', so no transcript

There was a problem finding a proper place to store configuration data.
The message was:
  Directory `/usr/local/texlive/2009/texmf-config/web2c' is not writable

To overcome such problems, set up the environment variable TEXMFCONFIG to
point to a directory tree that is writable to you, e.g.
  setenv TEXMFCONFIG $HOME/texmf

I did try setting up TEXMFCONFIG, but to no avail.

To make clear what I aim at: I'm on a system where I'm just a poor user; the TeX distribution is installed globally, so it's read-only for me as I don't have root permissions. Therefore, I want the changes installed in a local directory.

  • I suppose you installed texlive as root? – user2478 Dec 23 '10 at 12:09
  • @Herbert: No, the system administrator did. Sorry that I forgot to tell. – Hendrik Vogt Dec 23 '10 at 12:11
  • 1
    then you have to run updmap --enable Map=cmssmi.map, it uses your ~/texmf directory – user2478 Dec 23 '10 at 12:13
  • @Herbert: Thanks, that works. Great! Can you please add it as an answer so that I can accept it? (And: Do I get it right that with -sys it tries to install the font globally?) – Hendrik Vogt Dec 23 '10 at 12:23

then you have to run updmap --enable Map=cmssmi.map, it uses your ~/texmf directory

But it makes only sense, when you are a real user on a foreign machine.It will confuse your system, when you run sometimes the -sysvariant and sometimes the user variant.

  • What do you mean by real? I'm feeling rather real at the moment, or am I only imagining my existence? – Hendrik Vogt Dec 23 '10 at 12:36
  • 1
    "real" is that you do not have root access and are not able to mix the use of update-sys and update – user2478 Dec 23 '10 at 12:44
  • So that's where I wrote "poor". Thanks! (And please remember the "@Hendrik" thing :-).) – Hendrik Vogt Dec 23 '10 at 12:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.