2

I use the package:

\usepackage{xelibertine}

It works fine. But I do not know how to make the numbers old style. So I tried

\defaultfontfeatures{Numbers=OldStyle}

But it's not working.

How can I solve my issue?

  • 3
    You may try libertineotf: \usepackage[libertine={Ligatures=TeX,Numbers=OldStyle}]{libertineotf} should be the desired option. – egreg Oct 12 '12 at 11:17
6

The xelibertine package is quite old and unsupported. I find this in the SourceForge site of LinuxLibertine.org

Linux Libertine 5.0 is not working with the old xelibertine.sty. Will be an update soon?

The up-to-date interface to Linux Libertine for XeLaTeX and LuaLaTeX is the package libertineotf.

In order to get oldstyle digits, you can call it by

\usepackage[libertine={Ligatures=TeX,Numbers=OldStyle}]{libertineotf}
  • Do you know if this is still the standard way to invoke oldstyle figures? I’m currently just using \usepackage{polyglossia} with \setmainfont{Linux Libertine}, but it does not show oldstyle figures. Unfortunately, they are not mentioned in the package documentation. I do not currently use the libertineotf package. edit: I found the [Numbers=OldStyle] option. Thank you :) – Philipp Aug 23 '17 at 8:48
  • 1
    @Philipp Support of Libertine has changed through the years. \setmainfont{Linux Libertine}[Numbers=OldStyle] should be the current best way. – egreg Aug 23 '17 at 8:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.