I am working in Ubuntu 10.10 using Gnome. I wrote this:


\title{Papa Johns Cheese}
\date{Saturday 25 December 2010}




I get the above error message in the log file

! LaTeX Error: File `ucs.sty' not found

Now I have not used LaTeX since 1993, so I went to a beginners tutorial and wrote the hello script and it worked fine when I gave the command latex hello. No error. this started with \documentclass{article} So I wondered.

  • The document class should not change this. Did you change nothing else at all? – Joseph Wright Dec 25 '10 at 20:36
  • I did not change anything else. – Hubert Dec 27 '10 at 16:30

Does locate ucs.sty (on a command line) find anything? If not, you need to install the texlive-latex-extra package (eg. via Synaptic) or simply install texlive-full.

  • I installed texlive-latex-extra and then tried Locate ucs.sty and find -name ucs.sty. Still did not find any file. When I tried latex PapasCheese, it gave me the "File 'ucs.sty' not found" again – Hubert Dec 27 '10 at 16:31
  • It works now. I tried Ubuntu Software Center and searched for latex-ucs. The file given did not have ucs in it but I installed it and then I was able to compile the PapasCheese.tex file. It only gave a warning message about using something older than 2004. Thanks for the help! – Hubert Dec 27 '10 at 18:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy