11

I'm using Miktex 2.9 on windows 7 x32, texniccenter as IDE. I encounter an error for a project that worked few days ago: when I compile, I get the message:

! I can't write on file `../preamble1.aux'.

The beginning of the .tex file is:

\documentclass[xcolor=dvipsnames]{beamer}
\include{../preamble1}
\begin{document}

What should I do?

Thanks.

  • What is the contents of preamble1.tex? – xport Dec 26 '10 at 16:41
15

Why did you put \include in the preamble?

Please change to \input.

  • Thanks, it worked, but I do not understand: few days ago, the \include worked fine... I upgraded from Miktex 2.8 to 2.9 (uninstall/reinstall), this might be the cause? – lmsasu Dec 26 '10 at 16:43
  • 1
    @Imsasu, I haven't seen \include in the preamble. Even though you use \documentclass{book}, you can use \includeonly only and not \include in the preamble. It is what I know. :-) If you feel my answer is the final solution, kindly mark it with green check :-) – xport Dec 26 '10 at 16:47
10

See this answer for an explanation of why \input works and why \include does not, why this has changed with recent tex distributions, and how to work around it for old documents, if necessary.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.