5

I can use letters marked with diacritics in most parts of my document. Now, I'm making an epigraph

\epigraph{,evlos t'nac uoy melborp a si ereht fI''\\
''.ti dnif :evlos nac uoy melborp reisae na si ereht neht}{aylóP egroeG}

(the quote is written in reverse because I'm using LyX in Hebrew and that's the way to make it write left-to-right in an ERT).

Anyway, it doesn't compile. It does compile if I remove the 'ó'.

The error is:

Could not find LaTeX command for character 'ó' (code point 0xf3).

And its description is:

Some characters of your document are probably not representable in the chosen encoding. Changing the document encoding to utf8 could help.

Changing to utf8 does help if I don't use Hebrew in my document. The way I did it is through Document->Settings->Language->Encoding->Unicode (utf8).

But, if I do write anything in Hebrew in the document, then changing to utf8 causes the following error (per Hebrew character):

Package inputenc Error: Unicode Character '\u8' not set up for use in LaTeX.

3
  • 1
    Use \'o instead of the accented character.
    – egreg
    Mar 2, 2013 at 22:09
  • Sorry for the late answer; I usually don't look at LyX tagged questions. We had the "Answer the unanswered" session yesterday and it caught my eye.
    – egreg
    Mar 3, 2013 at 16:59
  • The final exam in the course where this document was used has just ended a few minutes ago, so it was just in time for the students to see the correct spelling :) Thanks.
    – user302099
    Mar 3, 2013 at 17:40

1 Answer 1

4

I don't know what's going wrong, as there's no real example. However, using the "command" syntax \'{o} instead of the UTF-8 character ó might solve the issue.

The result should be the same, because LaTeX just converts ó to \'{o} before proceeding on.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .