2

I have this weird issue with forward and inverse searches. I am using WinEdt + Sumatra combination. The forward and inverse search works perfectly on certain some .tex files, but fails on some others.

Currently, I am working on a .tex file and the inverse search always points to the end of a section. Where ever I double click in a particular section of the pdf, the inverse search points to the end of that section in the .tex file.

Moreover, when I try to perform forward search (Shift+F8) from the .tex file, the section in the pdf file doesn't get highlighted.

There are other .tex files where both the searches work perfectly. What could be the issue with this .tex file?

  • Also are you using \include, \import etc. ? – percusse Oct 25 '12 at 23:38
  • percusse: I am not using \include or \import. Kurt: The .tex file is a template that I have downloaded. So, I don't know which part might be causing the problem in order to build a MWE. If you do need to have a look at the template, it can be found here. pamitc.org/cvpr13/files/cvpr2013AuthorKit.zip And yes, I am sure that I have configured WinEdt properly. I have been using this configuration to edit 3-4 other .tex files and none of them have given me any problems. I am using WinEdt Build: 20120329 (v. 7.0). – Vittal Oct 26 '12 at 5:03
3

In TeXmaker synctex (i.e. jump to pdf or jump to source) fails if either the directory or the file name has a space. In TeXworks (and TeXnicCenter) synctex fails only if the file name contains a space. Maybe WinEdt behaves like TeXmaker.

Check if the offending file contains a space in its name, or if any of the directories used in the compilation process have a space in their names. Remember also to check if you have redirected the temporary or output files to separate directories.

1

Although it appears to be somewhat inconsistent, forward and inverse search fails when searching a .tex file identified in the first include statement used in a root .tex file. The error reported is a file not found message.

To fix the problem, I just added one more include statement where the file name is excluded. For example, in my root .tex file I originally had

\include{Introduction}
\include{LinearSystemsODEs}
% etc.

and I changed it to

\include{}
\include{Introduction}
\include{LinearSystemsODEs}
% etc.

The same problem occurs when an \includeonly statement is used.

0

You could have turned the "--src" option off. Click on it, to enable it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.