I run emacs and auctex 11.86 on debian stable. When i open a tex file with

$ emacs text.tex

Emacs shows the following line 38 times in the Compile-Log buffer

../../../../.emacs.d/elpa/auctex-11.86/font-latex.elc:Error: Don't know how to compile nil

My complete emacs configuration can be found online

1 Answer 1


I'm also running Emacs on Debian stable (Squeeze) and I have the same issue. The difference is that I'm using AUCTeX 11.85 from the Debian repository, while you're using 11.86 from the ELPA.

I don't think your configuration is the issue, rather, it seems there is a bug in the font-latex package, which is part of AUCTeX, which recent versions of Emacs have stopped silently ignoring. There is a thread on the bug-gnu-emacs mailing list that describes the issue in more detail.

The solution offered there is to upgrade font-latex. Unfortunately, the latest version of the auctex package in the Debian stable repository does not include the patch for this bug, nor does 11.86, which is the latest version in ELPA. So, I'm not sure there's a solution which will keep either your Debian or ELPA packages consistent.

You might try directly installing a newer version of auctex from either Debian testing or unstable. However, there might be dependency issues, so you could also try apt pinning, which will help resolve the dependencies for you.

My solution was to download the latest version of font-latex.el, byte-compile it, and replace the local files:

cd /tmp
wget 'http://cvs.savannah.gnu.org/viewvc/*checkout*/auctex/auctex/font-latex.el'
emacs -batch -f batch-byte-compile font-latex.el
sudo cp font-latex.* /usr/share/emacs/24.2.50/site-lisp/auctex/

Note that your path in the final command will be different, since I'm using the version of AUCTeX from the Debian package.

  • the compilation fails. Will i need more files? /tmp$ emacs -batch -f batch-byte-compile font-latex.el [...] In toplevel form: font-latex.el:44:1:Error: Cannot open load file: tex Commented Oct 27, 2012 at 16:44
  • 2
    It sounds like it's having trouble locating the file tex.el. You might try using M-x byte-compile-file from within Emacs instead, to ensure that your load-path is complete. Then point it to the font-latex.el file you downloaded in /tmp. This will produce the font-latex.elc file you need. Commented Oct 27, 2012 at 17:01
  • 1
    1) Thanks to Jason! BTW, the problem still apparent in emacs 24.3 which has been released ~ 10 days ago. 2) I had the same problem as Jonas, and indeed, byte compiling "inside emacs" was easy and worked. Commented Mar 25, 2013 at 9:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .