10

I run the MacTeX 2012 installer and it installed a bunch of apps and tools under /Applications/TeX. However, I can't find the latex executables.

There is no /usr/texbin, no /usr/local/texlive. If I try to generate a PDF in TeXShop it returns an error, because it doesn't find the executables.

Shouldn't the MacTeX installer install them too? Where are they located?

1

1 Answer 1

9

Reinstall

The MacTeX installer should have installed them in /usr/texbin or /Library/TeX/texbin. To check if the executables are installed anywhere, use the following:

$ which pdftex 

It should return:

/usr/texbin/pdftex

Or, for OS X 10.11 and above:

/Library/TeX/texbin/pdftex

If it doesn't, you'll have to re-install MacTeX.

Redownload

It could be your package is corrupt, to check run the following from the directory in which MacTeX.pkg is located:

$ openssl md5 MacTeX.pkg

The resulting hash should match the md5 sum from the download page.

If it the checksum doesn't match you should download it again, I recommend using the torrent.

13
  • I doesn't return anything unfortunatelly. The folder /usr/texbin doesn't exist on my machine. I tried reinstalling MacTeX 3 times now.
    – Jawap
    Oct 28, 2012 at 21:00
  • @Jawap Usually /usr/texbin is a symbolic link. Do you have /usr/local/texlive/2012/bin?
    – Corentin
    Oct 28, 2012 at 21:03
  • Hmm, reïnstalling fixed it in my case. You could try running FixMacTeX2012.pkg (located in /Application/TeX). When and how did you obtain the installer?
    – Silke
    Oct 28, 2012 at 21:04
  • Well running FixMaxTeX2012.pkg added a symbolic link at /usr/texbin pointing to /Library/TeX/Distributions/.DefaultTeX/Contents/Programs/texbin. However I have no /Library/TeX folder... I also don't have a /usr/local/texlive folder :-(
    – Jawap
    Oct 28, 2012 at 21:15
  • @Jawap have you verified your package using the instruction I added?
    – Silke
    Oct 28, 2012 at 21:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.