I think this is more like a bug for Texmaker. Here is description:

I'm using Texmaker on windows, and I wanted to add bibliography using:

\bibliographystyle{plain}   % (uses file "plain.bst")

I noticed that when I use the option ``Use a "build" subdirectory for output files'' (from Texmaker configurations in the Commands tab) the bibliography does not appear on the output file. Yet when I disable this option, every thing works fine.

Any ideas how to keep using the "build" subdirectory option? I want to keep using it cause it helps keeping things organised.

closed as off-topic by Marco Daniel, Mensch, Claudio Fiandrino, lockstep, clemens Jul 6 '13 at 13:12

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center." – Marco Daniel, Mensch, Claudio Fiandrino, lockstep, clemens
If this question can be reworded to fit the rules in the help center, please edit the question.

  • What commands do you use to compile and create the bibliography? – long tom Dec 7 '12 at 9:58
  • Hi Tom, I'm not entirely sure, but I guess this is the part related to bibliography: ... |bibtex %|... (% : filename without extension) – user18098 Dec 12 '12 at 12:20
  • maybe you can try adding the path manually to the bibtex-command? something like bibtex foobar\%.aux? – long tom Dec 14 '12 at 9:16
  • 1
    I tried to use the build folder without bibliography in Windows and the LaTeX compiler keeps creating all files in the current folder instead of the build folder. It seems like a bug so I filed it in Google code. In Linux the build folder works just fine though. – Evangelos Bempelis Dec 20 '12 at 14:14
  • A user also tried to put this comment in the question: I have the same problem using XeLaTeX. When I use XelateX instead of PdfLaTeX, and the option of using "built" folder is enabled, Texmaker cannot find the log file and also pdf file because it searchs them in "built" directory but XeLateX make them in the root folder of project....It seems this scenario also happen when bibTeX is used. – percusse Jan 4 '13 at 20:24