4

I use the package makeidx which works fine. When I try to format the index with file.ist I have a problem, as the options indent_space and indent_length don't have any effect at all. item_0 works fine nevertheless.

Can anyone help me?

  • Welcome to TeX.sx! Would you mind adding a minimal working example (MWE)? – clemens Nov 1 '12 at 20:40
  • 1
    Welcome to TeX.SX! As far as I know, indent_space is used for indenting lines in the produced .ind file, but it has no effect for the final typesetting. What precisely do you want to achieve? – egreg Nov 1 '12 at 20:41
  • What does it help to format the .ind file? I just want to reduce the indention in the final index. – Tina Giesler Nov 1 '12 at 21:00
  • 1
    You could use the package idxlayout to format the index. – user21511 Nov 1 '12 at 21:35
  • 3
    @TinaGiesler MakeIndex does nothing regarding the spacing parameters in the typeset index; for instance, item_0 default is to break a line in the .ind file and add \item in front of the entry; how \item is interpreted by LaTeX doesn't concern MakeIndex – egreg Nov 2 '12 at 10:30
4

As user21511 has commented, use my idxlayout package to tinker with the indentation of index entries and (sub)subentries. The most relevant package options (see the manual for details) are indentunit, hangindent, subindent and subsubindent, also have a look at itemlayout.

\documentclass{article}

\usepackage{makeidx}
\makeindex

\usepackage[unbalanced,indentunit=0.75em]{idxlayout}

\begin{document}

Some text.\index{An index entry long enough to cause a line break}%
    \index{An index entry long enough to cause a line break!A subentry}

\printindex

\end{document}

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.