5

When I have Umlauts in my BibTex file then I learned that it should be inserted as

H{\"o}ckel

The problem with this approach is, that inside the JabRef preview or when I export the database to e.g. html, it is still displayed as LaTeX code and not as Höckel. The same happens, when you have hyphenated names like

Hans"=Dieter

I could insert the Umlauts directly, but I'm not sure whether the encoding of the file is important and whether the BibTeX file encoding has to match the encoding of my LaTeX document. My German document is currently encoded with UTF8 since this seems to work in both, my Linux and my OSX setting.

Question: Is there an overall approach, where I can have a working BibTex file which is displayed with Umlauts and correct hyphens in JabRef? Especially, is encoding important and which should I use?

2
  • Could you set up a cascading style (CSS) file to control the look of the HTML file?
    – Mico
    Nov 7, 2012 at 0:49
  • @Mico I know only the basics of css and I'm not sure how to transform \"o to ö with it. Do you ever used css in such a way?
    – halirutan
    Nov 7, 2012 at 1:22

1 Answer 1

6

There is no need to insert Umlauts in such an old way. JabRef and LaTeX can handle Umlauts as well. Earlier Windows used the encoding latin1 as default (I believe). Unix systems were using utf8 as default and so there were incompatible.

However nowadays the default encoding is utf8 and so the files can be used OS independently.

3
  • 4
    That's right. If your bib-File is rather old, check in Jabref (Preferences->General->Encoding) that you use UTF8 and convert the file via iconv -f ISO-8859-1 -t UTF-8 jabref_old.bib > jabref_new.bib. It seems (tex.stackexchange.com/questions/97252/…) that \usepackage[utf8]{inputenc} is still needed, too.
    – mpy
    Mar 2, 2013 at 15:05
  • Thanks for the answer. I'll try this next week and let you know whether it works fine. @mpy Thank you too for your comment. I never came across iconv so far.
    – halirutan
    Mar 2, 2013 at 19:59
  • 4
    But bibtex does not handle some utf8 characters (umlauts) from bib files. It will look fine in JabRef but will give errors when compiling. Switching to biblatex/biber solves the issue.
    – remus
    Apr 24, 2013 at 19:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .