3

Although I've googled extensively to find a solution, most of the related information online is about babel. I'm working with polyglossia and can't get the pdf bookmarks to appear in greek, although I have unicode set for hyperref, I've tried the bookmark package and several other suggestions online.

Example:

\documentclass{book}

\usepackage{polyglossia}
\newfontfamily\greekfont[Script=Greek]{Liberation Serif}
\newfontfamily\greekfontsf[Script=Greek]{Liberation Sans}
\setdefaultlanguage[variant=sans]{greek}

\usepackage[bookmarks=true,bookmarksopen=true,
            bookmarksopenlevel=0,bookmarksnumbered=true,unicode]{hyperref}

\begin{document}

\chapter{Συμπεράσματα}
Συμπεράσματα

\end{document}
  • 1
    Could you please post an MWE that reproduces the issue? I use Polyglossia and Hyperref without any issues. – Jörg Nov 8 '12 at 13:40
  • @Jörg there you go, sorry I forgot to add an example. – alkar Nov 8 '12 at 13:53
  • 2
    This compiles fine on my machine and I have Συμπεράσματα as a bookmark in the PDF. Could it be font related? I used Minion Pro as I don't have Liberation. Anyway, remove unicode from the hyperref setup. You don't need it and it causes a Failed to convert input string to UTF16 warning. – Jörg Nov 8 '12 at 15:30
  • Thanks for the advice, I'll try with a different font and see if it works. – alkar Nov 8 '12 at 15:40
  • Actually, it was solved just by removing the unicode option in hyperref. Thanks! You might want to submit an answer so I can accept it :) – alkar Nov 8 '12 at 16:07
2

You just need to remove the unicode option in the hyperref setup and the bookmarks will be generated correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.