9

This is the first time I approach at drawing diagrams with latex. I have included the tkz library and the tkz library shapes.multipart. As my code is processed I get back a bunch of nasty errors, on top of the others there is

!Package pdg Error: Arrow end type ``stealth''' unknown. See the pgf package documentation for explanation.

I have been told I need to include the shapes.multipart package in my document in order to get rid of this error, but apparently it doesn't work. Can anyone please help me sort out this issue?

\documentclass[11pt,a4paper,oneside]{article}
\usepackage[italian]{babel}
\usepackage[utf8]{inputenc}
\usepackage{amsfonts}
\usepackage{amsmath}
\usepackage{amssymb}
\usepackage{centernot}
\usepackage{mathtools}
\usepackage{tikz}
\usetikzlibrary{shapes.multipart}

%opening
\title{Esame di Algebra}
\author{haunted85}

\begin{document}

\maketitle
\newpage

... blah blah... paper content

\subsection{} L'insieme proposto non risulta totalmente ordinato in quanto $15$ e $21$ non sono tra loro confrontabili, in particolare $15 \centernot\sigma 21$ e $21 \centernot\sigma 15$. 
\begin{tikzpicture}[->,>=stealth',shorten >=1pt,auto,node distance=2.8cm,semithick]
    \tikzstyle{every state}=[fill=blue,draw=none,text=black]

    \node[initial,state] (A)                    {$49$};
    \node[state]         (B) [below of=A]       {$35$};
    \node[state]         (C) [below left of=B]  {$15$};
    \node[state]         (D) [below right of=B] {$21$};
    \node[state]         (E) [below of=B]       {$4$};
\path   (A) edge    node{} (B)
        (B) edge    node{} (C)
        (B) edge    node{} (D)
        (C) edge    node{} (E)
        (D) edge    node{} (E);
\end{tikzpicture}
\end{document}
7
  • 7
    For the stealth issue, you need to add \usetikzlibrary{arrows}. You also miss \usetikzlibrary{automata}, that gets rid of all "option XXX unknown", but there is still an error.
    – T. Verron
    Nov 11 '12 at 10:56
  • Actually there are two: i do not know the key '/tikz/initial' and i do not know the key '/tikz/state' any idea on how to get rid of those as well?
    – haunted85
    Nov 11 '12 at 11:06
  • @T.Verron: What error do you get after including arrows, and automata? Nov 11 '12 at 11:17
  • @T.Verron Sorry I have totally missed the automata package, it works like a charm now. Thank you for your help!
    – haunted85
    Nov 11 '12 at 11:23
  • 1
    @T.Verron: I just added the missing \end{document} to the MWE.
    – Stephen
    Nov 11 '12 at 15:42

Browse other questions tagged or ask your own question.