Above is a terminal log for those who would make sense of it, but basically I have done the following things in order to get the lovely promises of Emacs' screenshots:

  1. Downloaded AucTeX through this question, which includes the package in question preview-latex
  2. Read README and INSTALL, ran ./configure as advised.
  3. Realized Xcode's awful habits and made make a thing in my actual path
  4. Ran ./configure again, 'successfully' - followed by make and make install
  5. Fired up Emacs, noticed the lack of menu (supposed to be tell-tale of a successful install) and then fired up proper emacs, to no effect.
  6. Ran ./configure again, but specifying which emacs to work with (Emacs.app/Contents/MacOS/Emacs), and it gave an error about not being able to find my texmf folder, so I ran it again with that (and the lisp directory, it couldn't find that either)
  7. Did some more research. Turned out I gave it the wrong lispdir at first (lisp instead of site-lisp). Tried the same call again with the modified option.

The most recent call I ended up making was line 2490 in the log above:

./configure --with-texmf-dir=/usr/local/texlive/2012/texmf                 --with-emacs=/Applications/Emacs.app/Contents/MacOS/Emacs                 --with-lispdir=/Applications/Emacs.app/Contents/Resources/site-lisp

Nothing has worked. Can anybody tell me what piece of this puzzle I'm missing? I'm running OSX 10.7.5.

  • I should note that the most reliable way to install packages now is through list-packages. Commented Oct 22, 2013 at 13:49

1 Answer 1


I have everything mostly working now. I neglected to actually load the packages in my .emacs file. I still can't get preview-latex to work right (keeps bombing out), but I'm going to keep researching that issue. I've also modified my default pdf viewer. Below is the relevant portion of my .emacs file:

 ;; Adds stuff to my PATH (LaTeX, etc) 
(setenv "PATH" (concat (getenv "PATH") ":/usr/texbin"))

 ;; Set the default LaTeX exec to pdfTeX
(setq TeX-PDF-mode t)

 ;; Load AucTeX!! :D
(load "auctex.el" nil t t) ;; loads tex-site in such a way so that it can be undone
(load "preview-latex.el" nil t t) ;; actual preview-latex

 ;; Sets the default PDF viewer to, well, the default PDF viewer.
(setq TeX-view-program-list '(("Shell Default" "open %o")))
(setq TeX-view-program-selection '((output-pdf "Shell Default")))

Then, I figured out that GhostScript was in fact not installed on my machine (as MacTeX 2012 should have done), so I just installed it. Now it's saying 'no preview images'. Working on that.

  • 3
    It's a sad day when your research to try to fix this problem brings you back to this same question. Commented Feb 24, 2013 at 15:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .