1

I created a LaTeX document on Windows using TeXworks with the MiKTeX package. When I copied the same .tex file over to Linux (Ubuntu 9.10) and tried to compile using TeXLive everything worked fine except the citations no longer linked to the bibliography.

My build process was pdflatex > bibtex > pdflatex > pdflatex. My imports in the preamble are:

\usepackage{cite}
\usepackage{graphicx}
\usepackage[pdftex]{hyperref}
\usepackage[all]{hypcap}

I'm not sure what differences there could be that would cause the citation links not to work, all other links work fine (links to figures and websites). Any ideas would be great.

  • did you update your two latex installations? They may differ a little bit – pluton Jan 6 '11 at 13:40
  • It's likely that ubuntu 9.10 has an old version of TeXlive on it. Even the latest ubuntu (10.10) has TeXlive 2009. I believe 9.10 had TeXlive 2007, so this might explain the difference. – Seamus Jan 6 '11 at 15:17
  • 1
    insert \listfiles as first line into your document and compare the file list at the end of the log file. However, there is no need for the option [pdftex] when running pdflatex. – user2478 Jan 6 '11 at 16:05
  • @pluton @Seamus: Thanks guys, I updated and it's working fine. Instructions can be found here: wiki.ubuntu.com/ubuntu-manual/authors How can I give you credit for the help? – Daniel Jan 10 '11 at 20:42
2

Updating to the latex version of TeX Live fixed the problem, instructions for Ubuntu users can be found here: https://wiki.ubuntu.com/ubuntu-manual/authors

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.