5

I don't quite know the mechanics behind bibliography and BiBTeX. I am using TeXworks to write a document, I modify the bib file with an external application. When I typeset the document (Ctrl+T), it gives the same error displaying the old version of the line.

I am sure I have changed and saved the file. I fiddle with the application a bit, and typeset again it reloads the newest version.

How do I force TeXworks to reload the fresh version of the bib file?

2
  • 3
    Run BibTeX from the Typeset menu. Does this not solve your problem? – Seamus Jan 6 '11 at 16:35
  • @Seamus: It works that way. But, even though pdfLatex+MakeIndex+BibTeX is selected it does not reload each time. – nimcap Jan 7 '11 at 8:16
4

It looks like what's happening is that despite "pdfLatex+MakeIndex+BibTeX" being selected, TeXworks only actually does BibTeX if the bibliography file has been edited from within TeXworks. (You could check this by editing your bib file and saving it through TeXworks.)

Like I said in my answer, you can force TeXworks to reload the bibliography file by explicitly running BibTeX from the Typeset menu.

2
  • 1
    It solved my problem also, but can I some how run both bibTex + pdfLatex so I don't have to choose every time? – Chris-Top Jun 14 '11 at 19:57
  • @Chris-Top I don't use TeXworks, so I don't know. Sorry. – Seamus Jun 14 '11 at 21:21
1

Another option is to delete the .blg file before recompiling. You can do this directly or via "File>Remove aux files" in TeXworks. This will force TeXworks to load your updated bib file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.