I just downloaded and installed Texmaker. I've never used any (La)TeX before.

When I click the Run button with an arrow next to "Quick build" I get an error saying "Could not start the command". Why? What do I need to do?

  • 1
    Welcome to TeX.sx! Did you also install MiKTeX or TeX Live?
    – doncherry
    Nov 26, 2012 at 19:27
  • Nope, didn't know I had to. TexMaker documentation says nothing of the sort :S But I'll try, thanks. Are there any differences between them that concerns a beginner?
    – David
    Nov 26, 2012 at 19:38
  • After isntalling MikTex, what should I do? :S
    – David
    Nov 26, 2012 at 19:43
  • I am not an expert on the differences, but I'd recommend TexLive with which you have all the packages downloaded and ready to go. I had an issue with MikTeX as I had installed it as admin (well I think that was the issue -- really did not spend time looking into it), and then switched to TeXLive (both on Mac and PC). Nov 26, 2012 at 19:45
  • 1
    @PeterGrill If you choose the MiKTeX Net-Installer, you also get all packages; however, the on-the-fly installation is pretty neat as well. Installing MiKTeX as admin is indeed rarely helpful, see the link in my answer.
    – doncherry
    Nov 26, 2012 at 19:55

8 Answers 8


(Also check out the MiKTeX tag wiki I just wrote up!)

The hardest part about getting started with LaTeX probably is learning what the different components you need are. Texmaker is an editor, but what actually compiles your source code and creates the document is within a (La)TeX distribution, the most popular of which are MiKTeX (Windows only) and TeX Live (Windows, Linux, OS X (as MacTeX)). You can read about some differences between the two at What are the advantages of TeX Live over MiKTeX?. I've always been using MiKTeX, which seems like a solid choice for a beginner to me. I am, however, considering trying out TeX Live as well.

If you decide in favor of MiKTeX, make sure to install the user mode (you're asked about that during the installation process), not in admin mode. It has nothing to do with multi-account configurations, but rather something network-y related. You can read about it at Difference between administrative and user mode of MiKTeX. But believe me, the user mode will make your life much easier. I wish I would've done it right away. (On another question that might come up before downloading MiKTeX: What is the difference between the basic MiKTeX and the complete MiKTeX?)

Once you installed a distribution, you might have to reinstall Texmaker if you want to avoid having to (find out and) type in all the paths yourself.

As introductory reading for LaTeX, I recommend The Not So Short Introduction to LaTeX2ε, which also has a section about the different parts of a working LaTeX system, if I remember correctly.

  • Thanks for the heads-up! I was about to install Miktex in admin mode, as I do that will all my apps. Feb 27, 2015 at 0:12

in my case I closed miktex-console then it works fine


I had the same issue(on Manjaro/Arch Linux). Delete / rename (safer) the .texlive directory in the home directory, and reinstall texlive-core. That would solve it.

  • Manjaro is not Arch.
    – cfr
    Nov 23, 2014 at 0:48
  • @cfr, No it isn't. But it uses the same repos. So the behaviour can be expected to be similar.
    – jadelord
    Dec 1, 2014 at 11:02
  • But it often is not similar as the record shows. Especially when things don't work properly ;). It is perfectly safe to delete ~/.texliveYYYY since it contains only generated files. (Unless somebody has deliberately put other things there for some reason.) I doubt you need to also reinstall texlive-core which won't (ought not) touch your home directory. It is probably a stale file or something if removing that directory solves the problem.
    – cfr
    Dec 1, 2014 at 12:16

i have the same problem with you but i solve it finally:) I should explain my situation first, i use windows 7. The reason for me to have the error is i just download MikTeX(really takes a long time) and NOT install MikTex from the package i download before.

Basically for Windows, 2 steps:

Step 1: install and download MikTex which is a distribution for windows (Note: remember to install after downloading all the package)

Step 2: download Texmaker which is text editor

Here are some useful guides for you if you use windows http://www.howtotex.com/howto/installing-latex-on-windows/ http://www.youtube.com/watch?v=RL15I-6NQFQ

Hope that helps you and enjoy you day:)


I had the same error message with the bibliography backend biber.

Error: Could not start the command: biber

And I had not installed the package biber. (!) After installing, everything went smooth.

So, first of all, take a look if the package or command is installed, that is, if it can be executed in terminal.


Ok so, I've been following the solutions proposed here. However, when I change the path for pdfLaTeX in the command section in preferences, I can compile but not compile & view. Any suggestions?


In my case (not for fresh install, but the relevant question is closed as a duplicate of this), the issue was that I added an argument to the pdflatex command line that tripped TexStudio up. In particular, I added -aux-directory=tex-build. While this works fine if run directly from the shell, for some reason it doesn't work from TexStudio, it seems the dash confuses it: I replaced that with -aux-directory=texbuild (notice that the value doesn't have a dash now) and it worked.


I just had this issue.

Symptom: which pdflatex or where pdflatex failed, meaning pdflatex was not found in any directory on PATH.

The problem seems to have been an overly long PATH environment variable. There's a systemwide one and a per-user one that gets appended to form the effective value.

I edited the environment variable; I reordered a few of the paths in there, moving the MikTeX path up.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .