2

Possible Duplicate:
Set limit to one author when using “et al.” in biblatex

I am using biblatex to manage the bibliography of a large document. Everything is working fine, but I have found a small problem that I am not able to solve:

I am calling:

\usepackage[style=authoryear, maxbibnames=99, mincitenames=1, maxcitenames=2, backref=true, hyperref=true, dashed=false, firstinits=true, backend=biber, bibencoding=utf8]{biblatex}

At the beginning of my document, and everything works as expected, viz.

\textcite{me2012} -> me (2012)

\textcite{me_and_you2012} -> me and you (2012)

\textcite{me_and_fred_and_dave2012} -> me et al. (2012)

However if I have another "me et al." in the document, the following thing happens:

\textcite{me_and_fred_and_dave2012} -> me, fred, et al. (2012)

\textcite{me_and_sarah_and_lucy2012} -> me, sarah, et al. (2012)

This is very annoying since it seems to be ignoring the mincitenames=1 given at the beginning. I was expecting:

\textcite{me_and_fred_and_dave2012} -> me et al. (2012)

\textcite{me_and_sarah_and_lucy2012} -> me et al. (2012)

Is there any way to block this behaviour?

marked as duplicate by lockstep, Reinstate Monica - M. Schröder, Stefan Kottwitz Nov 27 '12 at 14:21

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

migrated from stackoverflow.com Nov 27 '12 at 13:07

This question came from our site for professional and enthusiast programmers.

  • Sorry if this was a duplicate, I looked on the internet before posting and didn't really find anything until I turned up the vaguely related post I replied with! – EdwardAndo Nov 27 '12 at 20:37
8

Based on an answer from These guys, I have managed to work out that this behaviour is achieved by changing the \usepackage in the preamble to:

\usepackage[style=authoryear, maxbibnames=99, mincitenames=1, maxcitenames=2, backref=true, hyperref=true, dashed=false, firstinits=true, backend=biber, bibencoding=utf8, uniquename=false, uniquelist=false]{biblatex}

i.e., by adding uniquename=false, uniquelist=false to the list of options!

  • Great that you solved it, and thanks for sharing your findings. Remember that it's ok to accept your own answer, it'll help future readers know the correct answer. – Alexis Pigeon Nov 27 '12 at 9:38
  • 1
    Incidentally, if you use citestyle=apa, this breaks completely. Moral of the story? Always use citestyle=authoryear. – daviewales May 15 '13 at 14:44
  • Thanks for this, I was citing two articles with more than ten authors each, but for which the first ten authors were identical and in the same order, which produced the following atrocity: "bla bla (Rendu, Beauval, Crevecoeur, Bayle, Balzeau, Bismuth, Bourguignon, Delfour, Faivre, Lacrampe-Cuyaubère, et al., 2014; Rendu, Beauval, Crevecoeur, Bayle, Balzeau, Bismuth, Bourguignon, Delfour, Faivre, Lacrampe-Cuyaubère, et al., 2016)" – Pertinax Mar 10 '17 at 12:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.