When compiled with LaTeX + dvi2ps + ps2pdf the pdf output of the below MWE shows a strange behaviour:

On the first slide (without TikZ picture) fonts and colours are slightly different from the ones on the second slide (with the TikZ picture). For example, look at the black area in the footer. It is deep black on the first slide but becomes somewhat greyish on the second one. Also the font seems to change (it's "thicker" on the second slide) ... The phenomenon is best seen when the Acrobat Reader is set to display single pages and the zoom factor is small.

What the XXXX is happening there????

NB: There are no problems when the code is compiled with PDFLaTeX. The problem is that I have eps pictures in my presentation so that PDFLaTeX is no option (I could but do not actually want to convert the pictures from eps to jpg or pdf.)



    single arrow,                 
    single arrow head extend=2pt, 
    inner sep=2pt,                
    top color=white,              
    bottom color=#1,              
    drop shadow                   
  ] (A) {#2};%

  \uncover<1->{Lorem ipsum dolor sit amet.}

  \uncover<2->{\tikzarrow{yellow}{Then} Donec vehicula augue eu neque.}

PS: Possible connection with TikZ with "remember picture" compiled with pdflatex yields different results compared to dvips -> ps2pdf.

  • I have seen the same behaviour in my presentations. It seems unpredictable but the only common thread is that slides with "off" colour always contain included graphics. Not all slides with included graphics are effected though. – Marius Jansen Jan 23 '13 at 6:58

Such behaviour can have multiple causes. In general, beamer works badly with PostScript (you lose shadowing and other features). TikZ should work with PostScript, but very likely adds some color features that cause PDF files to "look ugly" on those pages, see e.g. Why are some pages in my PDF coming out bold? or Using opacity in TikZ causes strange rendering in Acrobat.

General solution is to convert your figures from eps to pdf using epstopdf program, and then use pdflatex directly. You can as well try to use the epstopdf package (not program!), whose usage is shown e.g. in epstopdf warning: "Shell escape feature is not enabled." .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.