I remember that a long time ago, when I was using Winedt (V5.0 I guess) it automatically replace some characters. For example, ç was replaced by \c{c} when I open the file.

Now, I need to do the same again. But I have Winedt 7.0 and I don't know how to translate all the accented characters automatically.

Any help?

  • what tex format are you using? if it's latex, you needn't bother -- use the inputenc package and it'll all happen automagically. – wasteofspace Nov 28 '12 at 12:50
  • 1
    You can activate/change translation tables in the options interface "Language, Unicode ...->translation tables". – Ulrike Fischer Nov 28 '12 at 12:59
  • @wasteofspace. I know that. But I must write in this way. I can not use any package. This is the rule (unfortunately). – Sigur Nov 28 '12 at 15:45
  • @UlrikeFischer. Thanks. I'll try and come back later. – Sigur Nov 28 '12 at 15:47

I know that this answer comes a bit late and you probably have managed to do it already... (at that time I wasn't a TeX.SX user yet).

In WinEdt 7 (and above) all customizations are made from the Options Interface accessible from the Options menu, which looks like:

enter image description here

To achieve what you want, select the Language, Unicode, Sorting, Translations... branch and then double-click on Translation Tables: the script TranslationTables.ini will open.

Now, if you want to write ç in the editor, but you want the document to contain \c{c}, you have to enable (i.e. set ENABLED=1) the "translation table" named TeX_Write. If you want WinEdt to show ç when you open a document containing \c{c}, you have to enable the "translation table" named TeX_Read.

The same can be done for .bib files, enabling the "translation tables" named BibTeX_Write and BibTeX_Read.

Note that all of them are disabled by default since starting with version 7, WinEdt has Unicode support.

Of course all of them can be further customized to accomplish your personal needs, by adding or removing characters that have to be "translated".

When you've finished with it, remember to click the button Load Current Script in the toolbar of the Options Interface to apply the changes (the first one on the left). Note that if you skip this step nothing will be changed in your configuration...

  • @Sigur Did it work? – karlkoeller Jun 27 '13 at 18:56
  • I'm on linux now. But next time when I use a Windows machine, I'll try it and inform you about the results. Thanks. – Sigur Jun 27 '13 at 19:00

If you use


in your preamble, you wouldn't need to convert those unicode characters at all. They would work as is.

  • Thanks. But please read my comment above. – Sigur Nov 28 '12 at 15:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.