3

I am writing a thesis using LaTex and I was told that my numbering cannot restart in the Appendices, which seems wrong to me but I'm not going to argue it. I am using the report class and the appendix command. It seems that the appendix command restarts the numbering when it is used. However, I would like to use the appendix command but not reset my page numbers.

\documentclass[12pt]{report}
\usepackage {fancyhdr}
\usepackage{graphicx, amssymb, changepage}
\usepackage{rotating}
\usepackage{setspace}
\usepackage{pgnumchapter_nums}
\usepackage{titlepg}
\usepackage{outlines}
\usepackage{appendix}

%              this is for the list of symbols page, if desired
\def\listofsymbols{\input{symbols} \clearpage}
\def\addsymbol #1: #2#3{$#1$\> \parbox{5in}{#2 \dotfill  \pageref{#3}}\\}
\def\newnot#1{\label{#1}}
%
\pagestyle{fancy}
% \fancyhead[LE,RO]{helv \thepage}
\fancyhead[L,R]{helv \thepage}
\setlength{\headheight}{15.2pt}     %%test this

%\fancyhead[LE,RO]{\thepage\hspace{2em}\footnotesize{\leftmark}}  % try this to move over header

\addtolength{\voffset}{-4em}                                % May2009 added this to move page number up a bit


\doublespacing

\lhead{}
\chead{}
\rhead{\thepage}
\lfoot{}
\cfoot{}
\rfoot{}

\renewcommand{\headrulewidth}{0 pt}          %this prints a line under the header
\renewcommand{\footrulewidth}{0  pt}         %this prints a line under the footer


\renewcommand{\contentsname}{\normalsize{Table of Contents}}
\renewcommand{\listfigurename}{\normalsize{List of Figures}}
\renewcommand{\listtablename}{\normalsize{List of Tables}}
\renewcommand{\bibname}{\normalsize{Bibliography}}
\renewcommand{\indexname}{\normalsize{Index}}



\pdfpagewidth 8.5in
\pdfpageheight 11in 

\setlength{\textheight}{8.5in} 
\setlength{\oddsidemargin}{0.5in}  
\setlength{\evensidemargin}{0.5in} 
\setlength{\textwidth}{6.0in}
\setlength{\topmargin}{0.in}    
\setlength{\headheight}{0.5in}
\setlength{\headwidth}{6.0in}
\setlength{\headsep}{0.65in}                                 
\setlength{\parindent}{12mm}



%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
%%%
%%%  This begins the frontmatter of the document, everything preceding the body 
%%%
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%


\begin{document}

\pagenumbering{roman}

\thesistitlepage

\thesiscopyrightpage              

\addcontentsline{toc}{chapter}{Abstract}                                % added May2009
\thesisabstract




\addcontentsline{toc}{chapter}{Acknowledgments}                 % added May2009
\thesisacknowledgments

\makeatletter \renewcommand{\@dotsep}{10000} \makeatother


\renewcommand{\contentsname}{\normalsize{Table of Contents}}      % added this line May2010 to fix issue with 
\tableofcontents                                                 %toc appearing in too large a font size when used in Linux




\newpage        % added June 2009


\newpage     % added June2009
\addcontentsline{toc}{chapter}{List of Figures}                     % added May2009
\listoffigures



%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
%%%
%%%  This begins the body of the document
%%%
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%


\newpage
\pagenumbering{arabic}


\include{chapter1}

\include{chapter2}

\include{chapter3}

\include{chapter4}

\include{chapter5}

\include{chapter6}

\addappheadtotoc
\include{chapter7}

\pagenumbering{arabic}
\appendix
%\appendixpage
\renewcommand\chaptername{Appendix}
\include{appendixA}

\include{AppendixB}

\bibliographystyle{plain}
\newpage
\addcontentsline{toc}{chapter}{Bibliography}        % added May2009
\nocite{*}
\bibliography{source2}


\end{document}

Any help in this matter would be great. Thanks!

1
  • It would be better to add a MWE to your question which shows the problem. – Vahid Damanafshan Nov 28 '12 at 16:47
7

\appendix in report class does not reset the page counter so something else must be doing that. Most likely calling \pagenumbering so

  \renewcommand\pagenumbering[1]{}

would disable that.

1
  • 4
    Oh you added a MWE well yes if you are calling \pagenumbering explicitly then you can more simply just not do that rather than redefine it to do nothing:-) – David Carlisle Nov 28 '12 at 16:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.