This is the first time that I compile a LyX file with some EPS picture inside on my current computer. I already did that before on other computers, without any problem.

But here, the result is pixelized. All the document can be compiled, and is rendered nicely, but the EPS file is pixelized. I know it is not due to my EPS file which is really in vectorial format because I can open it with other readers and zoom inside without any problem. Result : enter image description here

I tried to figure out which options I should activate or which converter I have to set but didn't find anything. This guy had the same problem than me : Link but I think he is working on a Windows OS while I am on Mac OS, and the resolution don't seems to work for me.

EDIT : I tried for instance to set EPS to PDF (ps2pdf). The result is no longer pixelized but... takes the whole page, as a PS file. Here is an image of the result and the parameters : enter image description here

EDIT again : Trying to use epstopdf is not working, image still pixelized, but maybe I don't use the correct parameters ? I was expecting something as 'PDF (epstopdf)' in the list but there is none of these. enter image description here

  • Did you try opening the file with another pdf viewer?
    – T. Verron
    Nov 28, 2012 at 18:18
  • Yes, with the same result.
    – AnSy
    Nov 28, 2012 at 18:23
  • For the "whole page when converting" problem, you could try tools such as pdfcrop.
    – T. Verron
    Nov 28, 2012 at 18:52
  • If it is a real EPS file with a correct bounding box, then ps2pdf -dEPSCrop helps to get rid of the additional margins. Nov 28, 2012 at 19:22
  • 1
    Since you are in a Mac, you can use epstopdf instead of ps2pdf, which produces the correct bounding box.
    – JLDiaz
    Nov 28, 2012 at 23:34

1 Answer 1


I had to use the package epstopdf and to correctly configure the converter in LyX preferences. Then, reconfigure a bunch of times (it didn't work the first time...) but after doing the usual steps (quit and start the program again and so on) it worked. Thanks to JLDiaz for the answer !

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.