12

I modified color scheme of editor to use darker colors, but there is no current line highlighting option. So I can't remove bright white highlighting of the current line.

Is there a way to disable highlighting of the current line or to change its color?

14

Options --> Configure TeXstudio --> Syntax highlighting. In the list of all the highlighting options, scroll almost to the bottom, to the end of the Line highlighting part. There you will find current, where you can define the colouring for the current line. The middle colour is the background colour.

enter image description here

Old answer, which probably applied to an older version of TeXstudio

Options --> Configure TeXstudio --> Editor. In the list of all the highlighting options, scroll almost to the bottom, to the end of the Line highlighting part. There you will find current, which defines the background colour of the current line.

enter image description here

  • Thank you, that is what I wanted! Sorry, I thought that if colors are not defined, they should be transparent, so I haven't even tried to change these values. – Edward Ruchevits Dec 1 '12 at 16:24
  • This modifies the color of the highlighted line. But what about the current paragraph? Even if you don't select anything the paragraph where the cursor is changes its color to grey. And it could be quite a little bit annoying. How can I disable it? – skan Feb 3 '20 at 19:11
  • 1
    @skan I don't think there is a "paragraph concept" in this context. But if you write a lot of text without adding line breaks, and line wrapping is enabled, what is actually a single line in the file, is displayed across multiple lines in the editor. If line numbering is enabled you can probably see that the same line number applies to your entire "paragraph". I guess adding line breaks in the code is the best fix. Can't see an option for doing what you ask, but you could add a feature request at github.com/texstudio-org/texstudio/issues – Torbjørn T. Feb 3 '20 at 19:26
2

For those of you who can´t find that setting under "Editor": See this little checkbox on the bottom left saying "Show Advanced Options"? Click it and go to the new point "Syntax Highlighting", scroll down to "Line highlighting" and here you go :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.