I am using Mikitex + Texmaker for writing a IEEETrans paper and i am a novice in all this. I have a test file which I am using for understanding how to insert bibliography. Thus, I have two files namely test_bb.tex and bb.bib. I have made all the settings as mentioned in this link on the same forum

Configuring TexMaker and BibTex

Here is the code snippet of settings after using wizard

pdflatex -synctex=1 -interaction=nonstopmode %.tex|bibtex %|pdflatex -synctex=1 - interaction=nonstopmode %.tex|pdflatex -synctex=1 -interaction=nonstopmode %.tex

so when I compile the test_bb file manually one by one (PDFLaTeX -> BibTex -> PDFLaTeX -> PDFLaTeX) or by quick build (as set in wizard of Texmaker) I get following stupid error while doing BibTex. Both bib and tex files are at the same location. I can't see the references and citation at all. even I have tried it after deleting log and aux files in build folder but no success.

This is the error

Process started

I couldn't open file name `test_bb.aux'

Process exited normally

The code snippet is as under for both files

tex file

\title{Sample IEEE paper style using Latex}
\author{\IEEEauthorblockN{Author first, Author Second, and Author Third}
\IEEEauthorblockA{Department \\
 City - State - Zip \\
 Email: [email protected]}
   This is an abstract.
  Here is a modified text sample for intro section using latex. This is a citation   \cite{author1} This is how you refer a section in another section Section~\ref{sec:meth}     ..... 
  This is the other section that you can use.

and bib file is as under:

 author = {John Frederik Camelot Smith and Jason Bourne},
 title = {{The Pain of Having a Foolish Name}},
 journal = {Journal of Modern Fiction},
 year = {2009},
 volume = {52},
 pages = {114},
 number = {1},
 issn = {0010-4620},
 publisher = {Grendel Publishing}

Please help...

  • 2
    welcome to tex.sx, does the first pdflatex run run to the end and leave a test_bb.aux file in the current directory? If there are other tex errors stopping the first run writing the aux file, then later bibtex or pdflatex runs are going to do the wrong thing. Generally it's easier to help if you can make a complete small tex document that shows the problem rather than just a fragment that we can't run locally. Dec 1, 2012 at 13:02
  • @David The aux file is in a default build folder. After first run I only get two warnings i.e 1. citation author1 on page 1 is undefined. 2. There were undefined references. (The above post is edited and whole code is added). I am pretty new in Latex and only knows this I don't know how to show a problem document.
    – Skipper07
    Dec 1, 2012 at 13:16
  • 1
    @Skipper07 I would recommend starting with TeXNicCenter if you're new to LaTeX. It eases the build process a lot. Simply install, run, tell it where to find MikTex, create a new document, set up a project (using Project->Create with Active Document as Main File, check BibTeX) and build project 3 times :)
    – recluze
    Dec 1, 2012 at 13:26
  • I have noticed the same thing. Texmaker does not seem to be very robust with its source file handling. It simply does not play well with Bibtex. I just spent about an hour trying to get it to work, to no avail. Finally, I fired up TexWorks (came with the MikTex Package) and ran bibtex from there. It worked fine, no problem. Texmaker refuses to work right. Possible issue: do you use the 'Put output files in build directory' option? That may break things.
    – Chris
    Feb 3, 2013 at 16:43

8 Answers 8


If you are using a ´build´ subfolder for your output files, the generated aux file will be placed there. A simple way to solve this problem is to edit the configuration of Texmaker.

bibtex build\%

This should do the trick. Try to run Bibtex, this should work fine. If you want to use your own defined sequence of executing (PDFLatex BibTex PDFLatex PDFLatex) you need to update that one as well, since this is still stuck with the old bibtex command (without the build\ addition). See the screenshot below for the implementation in the texmaker configuration screen:

enter image description here


Change bib(la)tex command line property to:

bibtex build/% -include-directory=build

This enables BibTeX to find not only main file but also indirectly referenced .aux files.

  • 1
    This works very well.
    – machinery
    Jul 7, 2016 at 9:33
  • 2
    This is the only working one I have come across for TexStudio on Windows.
    – Diaa
    Aug 11, 2016 at 18:26
  • 1
    This is the best answer. Jan 23, 2017 at 11:34
  • 1
    This worked for me too. The important bit is -include-directory=build. I noticed the error OP mentioned only happens if your main LaTeX file is composed of multiple other tex files (you have \include and you are building the master document). Since I don't usually work with documents containing multiple tex files, adding build/% used to be sufficient...
    – Maghoumi
    Jun 4, 2017 at 19:14
  • This was also the problem with me, after checking I was already doing: tex.stackexchange.com/a/106525/36389 . After reading about '\input' VS '\include' (tex.stackexchange.com/a/250/36389) and checking it worked well with '\input', I reached your answer. This solved the errors when compiling biblography, the ordering in the final document, and a strange behaviour of \nocite{*}.
    – Andrestand
    Jan 29, 2019 at 12:05

There is nothing wrong with your input: pdflatex, bibtex, pdflatex, pdflatex, produces the result below.

I would guess that pdflatex (or your editor) have been configured to write the .aux file to somewhere other than the directory containing the tex file, and then bibtex can not find it.

So the solution would be not to do that but I haven't used that editor so I can't help with the settings. Making this an answer rather than a comment for ease of formatting.

enter image description here

  • 2
    Your guess is right. I have just changed the settings that the .aux file shouldn't be written in a build folder and everything works fine...Thanks a lot...I was trying to solve it for last 2 days and you made my day.
    – Skipper07
    Dec 1, 2012 at 13:32

With TeXworks, give the same name to the LaTeX file and the BibTeX file. For example:



compiling myfile.tex yields myfile.aux.


I too was struggling with this problem, I'm quite the newbie (third day at it) when it comes to TeX and I've been at this for a couple of hours now. The solution (yes, I found one :D) was to use the executable 'miktex-bibtex.exe' (came with MiKTeX repository, installed for me under /MiKTeX/miktex/bin/x64[comment: I'm on 64 bit]/) as Texmaker's Bib(la)tex default ('Configure Texmaker', 'Commands' tab). One of the previous posters gave me the idea, he commented that the document compiled correctly under TeXworks (and it did for me too!), so I looked up wat executable TeXworks uses and put it in Texmaker.

I don't have a clue how or why this works, but it does so I'm hoping I can help somebody out here!


This is probably a minor case. I notice that in my case this problem happens just because the bibtex file has a different name (ref.bib) as compared to the main tex file (top.tex). The issue is resolved after I change ref.bib to top.bib.

  • 1
    As long as you give the correct name of your .bib file in \bibliography{...} it does not matter how your .bib file is called (with the exception of some special characters which should be avoided) Oct 19, 2017 at 21:25

I had a similar problem with Texmaker on Ubuntu16. My main tex file and bib file are in the same folder. To summarize, what worked in my case was to:

  1. give the bib file the same name as the main tex file, e.g. "mainfile.tex" and "mainfile.bib" for the bib file; then
  2. change the Bib(la)tex option (Options->Configure Texmaker->Commands) to "bibtex %" (note, I'm not using a "build" folder, so the box is unticked).
  3. To compile, I go to the main tex file and press the sequence F6->F11->F6->F6, or alternatively, on the main tex file, run the menu bar option PDFLaTeX, then run the BibTeX option, then run the PDFLaTeX option again TWICE.

My solution is a combination of some of the previous answers like that of @ionona. None of the suggested answers worked, in my case, exactly the way suggested (my Texmaker did not even recognise the build option bibtex build/% -include-directory=build as suggested by @gnod.

  • Use overleaf. Everything resolved.
    – Skipper07
    Jan 28, 2020 at 5:52

if you are using texmaker then go to 'Options' which is on the middle right of texmaker interface and then go to 'Quick Build' after that select 'PdfLaTeX + Bib (la)tex + PdfLaTeX (x2) + View Pdf'. Return to your tex file and run it again and the difficulties will be sorted out.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .