60

I got this error while trying to run the latex command:

! Undefined control sequence.
l.10 \newblock Available from: \url
                                   {http://www.google.com}.
? 

Why is it an undefined control sequence?

10
  • 65
    Does \usepackage{url} help? Dec 4, 2012 at 22:51
  • 14
    I had the same error and searching for my error message resulted in this page as a first hit so this question is indeed relevant, please remove the "closed as too localized" badge.
    – Gergely
    Jan 26, 2015 at 15:48
  • 3
    The first comment "\usepackage{url}" resolved this problem. Mar 9, 2015 at 22:58
  • 4
    I second @Gergely. I had the same error, and this is the first hit. The first comment \usepackage{url} solved my problem. Aug 13, 2015 at 14:15
  • 2
    I have a similar error but with href, anyone know how to fix it? Nov 18, 2017 at 4:03

1 Answer 1

4

Use

\usepackage{url}

if you just want the command \url{}. If you want hyperlinks, use

\usepackage{hyperref}

instead, loading it last (or almost last) in your list of packages. If you'd like nice bookmarks, use

\usepackage{bookmark}

instead.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .