Just as a preface: I'm still very new to Latex. So I have a package that I wrote to work on top of the base letter class to add some custom functionality (letterhead, fonts, formatting, etc.) On the Linux and OSX machines I've tried everything works totally fine (using pdfLaTeX or latex -> dvips -> ps2pdf), but on Windows using MiKTeX and pdfLaTeX compiling a letter with just the letterhead (which uses the font in question) fails with the output:

Trying to make PK font ruhvr8rc at 600 DPI...
Running miktex-makemf.exe
miktex-makemf: The ruhvr8rc source code could not be found.
Running ttf2pk.exe...
miktex-makepk: PK font ruhvr8rc could not be created.

I already have the file ruhv8rc.600pk in the MiKTeX tree (C:\Program Files (x86)\MiKTeX 2.9), in the same sub-directory as it is on the other systems, and I've refreshed the file name database with and without admin privileges. On the other machines I've tried this was enough, just copying the fonts into the font directory and running

sudo texhash


sudo mktexslr

did the trick.

So my question is: what are the differences between the MiKTeX tree and the TeX Live (texmf) tree that are causing this problem?

I've read similar questions, but the most common answers all involve map files, which I do not have (and haven't needed on any other distribution). I have only .xxxpk files and .tfm files for the font causing trouble.

  • Using MiKTeX 2.9 and pdfTeX 3.1415926-1.40.11 (with pdfLaTeX format) on Windows 7 64-bit. Commented Dec 5, 2012 at 19:06

1 Answer 1


The naming/storing convention of pk-files in miktex are different. miktex will not use the extension (600pk) to denote the resolution but a folder. E.g. I have 600 dpi pk in this location:



You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .