So I have a paper that I'm writing. I want MLA citations, footnoted. So I use biblatex-mla, and do the


hack so that I can use the autocite=footnote option. I'm pretty sure this is the right way to footnote MLA citations. But moving on.

I use the following code in test.tex:





And into test.bib I put

    title={Fundamentals of astrodynamics},
    author={Bate, R.},
    publisher={Dover publications}

This outputs


Works Cited

Bate, R. ...

^1 R. Bate. ...

As it should. However, this doesn't work with the @online entry. It compiles fine, but Works Cited is empty and the footnote is just ^1 .


Anyone know of any addition, hack, third-party package, etc. that will let biblatex-mla recognize @online sources?

Or even, does anyone know of any other package that allows MLA footnote citations?

EDIT: For now I changed the entry from @online to @article, which is recognized by biblatex-mla. Good enough for now.

2 Answers 2


I've added support for @online entry types to the version of biblatex-mla currently in development. You can find it here:


The handbooksamples.bib file includes a sample @online entry to show you where things go. I base the data and the formatting commands off of Diana Hacker's online guide to MLA, specifically this entry here:


    Author = {{Grammar Girl}},
    Date = {2008-09-16},
    Mainsubtitle = {Quick and Dirty Tips for Better Writing},
    Maintitle = {Grammar Girl},
    Nameaddon = {Mignon Fogarty},
    Publisher = {Macmillan},
    Title = {What Is the Plural of `Mouse'?},
    Url = {http://grammar.quickanddirtytips.com/the-plural-of-mouse.aspx},
    Urldate = {2013-03-24}}
  • My original project was buried under the weight of numerous upgrades and reformats since when I first asked this question, but this is supremely appreciated nonetheless! I'll whip up a new document now, and report any bugs I find. Best use of a +1 in a long time.
    – pmelanson
    Mar 25, 2013 at 22:37
  • For now, I'm still implementing some of these changes, so the update of Biblatex-mla isn't yet in CTAN. Download the appropriate files from GitHub (at that link), and put them in the same file as your .tex and .bib files in order for that version of the MLA style files to be the ones that get called. And yes, please, do let me know if you find any bugs (or even if you have problems getting your testing system up and running)!
    – jmclawson
    Mar 25, 2013 at 23:02

This is intentional; biblatex-mla doesn't support all of the default entry types. Its bibliography style file contains the lines


and does not define a driver for the @customa entry type. One quick way around this is to alias @customa with a supported type in your preamble:




Another option would be to define your own bibliography style file, say my-mla.bbx, based on mla.bbx but without the above aliases. You could then load biblatex with


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .