I'm rather new to the whole TeX experience and try to make a template to use for my masters thesis. Everything has been smooth except getting the references/bibliography right. I've spent numerous hours here, on CTAN and other sites to set up a Harvard style system.

I finally got it working using biblatex with bibtex as backend but one problem remains. There is no spacing between each entry. Normally there would be an indent but since I use the parskip package they are removed and for some reason the space that replace the indent in the body text does not appear in the bibliography.

I've made a minimum working example showing my problem plus one more thing that is acting weird, the whole .bib file is printed even if all works are not cited.

I would very much appreciate getting some help with this. Have spent hours trying different solutions proposed to similar problems without much luck.

I'm currently compiling with XeLatex and I'll try to provide additional details if needed. The whole thing is a little bit confusing still.

Here follows my working example:

\usepackage{avant} %fontpack

\title{Biblatex test}






My .bib file called test.bib:

author = {Penguin},
title = {Cold},
date = {2012-10-05},

author = {Cat},
ALTeditor = {editor},
title = {Google},
date = {2012-12-10},
url = {www.google.com},

author = {Dog},
title = {Running},
journaltitle = {Happy hound},
date = {2012-11-15},
  • 1
    Welcome to TeX.sx! Usually, we don't put a greeting or a "thank you" in our posts. While this might seem strange at first, it is not a sign of lack of politeness, but rather part of our trying to keep everything very concise. Upvoting is the preferred way here to say "thank you" to users who helped you. Dec 10 '12 at 19:03
  • 1
    For this "All bib entries show up even if not cited" thing: have you made sure that you re-ran latex bibtex latex (or xelatex or whatever in your case replaces latex) after commenting the citation of the third entry? With me everything compiles fine here and the third reference doesn't show up. Dec 10 '12 at 19:11
  • Must be an issue with my settings somehow then. I tried both the build and compile button and nothing change. I have suspected this for a little while since no notable change appeared while trying different solutions earlier this evening. Perhaps I should try a different editor for that part of the question and compare. Thanks so far! Dec 10 '12 at 19:15
  • Maybe your editor has a dedicated button to call bibtex explicitly and without having to go through the whole build process. Dec 10 '12 at 19:18
  • Moved from texstudio to texworks and still get all three references for some reason. A little odd. Dec 10 '12 at 19:20

In order to get a blank line between bibliography entries, you simply need to set the \bibitemsep length:


You don't need to redefine the bibliography environment to do this.

You also need to tell biblatex that you are using the bibtex backend:

\usepackage[style=authoryear, backend=bibtex]{biblatex}

and you should use


instead of \bibliography{<bibname>} (which is now deprecated).


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.