5

With the code (typeset with XeTeX)

\font\orn="Ornements ADF" at 12pt
\centerline{\orn\char70\quad\char57\quad\char102}
\centerline{\orn\char102\quad\char57\quad\char70}
\centerline{\orn\char70\quad\char116\quad\char102}
\centerline{\orn\char102\quad\char116\quad\char70}
\centerline{\orn Q\quad\char57\quad q}
\bye

I have this result

enter image description here

As you can see some glyphs are cut on the right edge.

Where is the error? How can I improve the rendering?

[edit] The only strange thing I can see is in the terminal:

This is XeTeX, Version 3.1415926-2.4-0.9998 (TeX Live 2012)
 restricted \write18 enabled.
entering extended mode
(./test031.texFontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
 [1]Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
 )
Output written on test031.pdf (1 page).
Transcript written on test031.log.

Maybe the "fontconfig warning" has something to do with this error.

/etc/fonts/conf.d/50-user.conf has this content

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
    <!-- Load per-user customization file -->
    <include ignore_missing="yes" prefix="xdg">fontconfig/conf.d</include>
    <include ignore_missing="yes" prefix="xdg">fontconfig/fonts.conf</include>
    <!-- the following elements will be removed in the future -->
    <include ignore_missing="yes" deprecated="yes">~/.fonts.conf.d</include>
    <include ignore_missing="yes" deprecated="yes">~/.fonts.conf</include>
</fontconfig>

[edit 2] I've tried the code on another computer and the result is the same.

6
  • I downloaded the OT font and tried (Mac OS X), getting the correct result. Please note that my correction about "typeset" and "cut" was right.
    – egreg
    Dec 14, 2012 at 17:34
  • I don't think that the warning is relevant. Are you using the OpenType or the TrueType version?
    – egreg
    Dec 14, 2012 at 21:02
  • @egreg I'm using the version of TeXlive2012, type1, at /usr/local/texlive/2012/texmf-dist/fonts/type1/arkandis/adforn. There are not OpenType or TrueType version on my system. Dec 15, 2012 at 9:15
  • 1
    I don't think it's a good idea to use a Type1 font for that. At the ADF site you can download the OpenType version: arkandis.tuxfamily.org/adffonts.html
    – egreg
    Dec 15, 2012 at 11:10
  • @egreg I've downloaded and installed the OpenType version of OrnementsADF but the result is the same. Dec 15, 2012 at 15:07

1 Answer 1

3

SOLVED.

The problem was with the pdf reader. Evince 3.6.0 on Linux Mint 14 Nadia Cinnamon displays incomplete glyphs. Tried with Acrobat Reader (Linux version) and the pdf is displayed correctly.

Had a great help with this issue from zappathustra on comp.text.tex

EDIT I tried to contact someone at the evince project to report the bug, but I wasn't able to. It would be very nice if someone here smarter than me could do that. Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.