23

I use \Pi and \Sigma in my math equations however, they are not printed in italic like other text. I guess this is because they are symbols and not really text. Putting \textit into the equation has no effect at all. Is there a way to italic these symbols?

2 Answers 2

18

amsmath defines the uppercase greek to follow math alphabet switches:

enter image description here

\documentclass{article}
\usepackage{amsmath}

\begin{document}

$a +\Sigma + \Pi$

$\mathit{a +\Sigma + \Pi}$

\end{document}
2
  • 1
    note that the shape of the \mathit a is not" the same as if it's just an ordinary math a (this is true for computer modern, but it may not be for other fonts). \mathit is ordinarily used for italic *words in math environments; single letters are assumed to be variables so the style is adjusted slightly. in this way, a math variable a can be distinguished visually from the article "a" in english; in other languages, other single letters sometimes have non-mathematical semantics. Dec 16, 2012 at 18:14
  • \mathnormal will do here as well for the Greek letters and typeset an ordinary math a
    – user4686
    Dec 16, 2012 at 18:27
22

If you always want the uppercase Greek letter in italics, the easiest method is to load amsmath and change the meaning of \Gamma and similar commands:

\documentclass{article}
\usepackage{amsmath}

\let\Gamma\varGamma
\let\Delta\varDelta
\let\Theta\varTheta
\let\Lambda\varLambda
\let\Xi\varXi
\let\Pi\varPi
\let\Sigma\varSigma
\let\Upsilon\varUpsilon
\let\Phi\varPhi
\let\Psi\varPsi
\let\Omega\varOmega

\begin{document}
$\Gamma \Delta \Theta \Lambda \Xi \Pi
\Sigma \Upsilon \Phi \Psi \Omega$
\end{document}

enter image description here

If instead you need both varieties, then input the italic ones with the var prefix: \varGamma and so on.

Note that some font packages, notably kpfonts and fourier, allow for options that decide whether using by default italic Greek uppercase in math.

7
  • @Josh Welcome to TeX.SE! When you have enough reputation, don't forget to upvote answers that helped you- it rewards those that looked at your question with 10 reputation points :)
    – cmhughes
    Dec 16, 2012 at 17:22
  • That doesn't work for me. I'm still getting an upright gamma for \Gamma and an italic gamma for \VarGamma. Is there a new solution, to fix that via options of amsmath? Do I have to defeine all my let commands after \begin{document} (which I think quite annoying)?
    – LaRiFaRi
    Jul 19, 2013 at 13:55
  • @LaRiFaRi Please, make a new question with all that's needed to understand the problem. The minimal example above works, so you must have a different set up for your document.
    – egreg
    Jul 19, 2013 at 13:57
  • [tex.stackexchange.com/q/124697/32245]
    – LaRiFaRi
    Jul 19, 2013 at 14:21
  • 1
    @AdrianKeister Look at the upgreek package.
    – egreg
    Jun 21, 2014 at 19:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .