I have trouble spell checking my document in TeXstudio. When I press spellcheck, I get the error No dictionary Available. Am I supposed to install a dictionary separately? How? Any suggestion?

up vote 97 down vote accepted

TeXStudio uses the OpenOffice spelling dictionaries (as well as thesaurus). You can download any number of them from the OpenOffice extensions site. You can also download dictionaries from LibreOffice extensions. The OpenOffice files have the extension .oxt but are actually .zip files. You place the dictionary files in the Dictionary folder in your TeXstudio installation. The dictionary then appears in the list when you open the "Configure TeXstudio" under "Options" in TeXstudio.

The following applies to versions before 2.7.2, newer versions (after a bug-fix in 2.11.2) recognize the `.oxt' extension so steps 2 and 3 become superfluous.

So here are the steps:

  1. download your dictionary (.oxt)
  2. change the extension to .zip
  3. unzip the files in a folder
  4. In TeXstudio preference, under Spell Checking Dictionary, change the directory to the folder you put your dictionary in
  5. reset TeXstudio.
  6. You are all set!
  • 2
    If you (like me) want to use multiple dictionaries you can copy the xx_XX.dic, xx_XX.aff and optional .dat,.stopWords and.badWords from the file into the common folder. – dtech Sep 22 '13 at 12:30
  • The dictionary pages have been updated, I've found the extension link by checking version history. There there were links provided to the latest language versions. – Sam Vloeberghs Mar 13 '14 at 7:31
  • @dtech Could you please specify what exactly you mean with "common folder"? :) – henry Oct 13 '14 at 20:06
  • @henry You put all the different dictionaries in a common folder of your choosing, and then set the TeXstudio preference to that folder. The folder could for example be C:\Program Files (x86)\TeXstudio\Dictionaries or C:\Users\Yourname\OOo dictionaries, you create it yourself. – dtech Oct 14 '14 at 10:20
  • @dtech I see, thanks! – henry Oct 14 '14 at 12:31

you may need to set the dictionary path in two places:

  1. Options>Configure TexStudio>General>Dictionary [Dictionaries spelling directory]
  2. Options>Configure TexStudio>Grammar>Internal [Wordlist Directory]

I was having the same problem in Mac OS. Here's how I solved it.

  1. Find the texstudio app, right click on it and select 'Show Package Contents'.
  2. Within the contents folder, right click on the 'Resources' folder.
  3. Press and hold alt. This should make the option 'Copy "Resources"' change to 'Copy "Resources" as Pathname'. Select this option.
  4. In texstudio, select to TeXStudio->Preferences->Language Checking.
  5. Paste the copied path name for your resources folder into the 'Spelling Dictionary Directories' textbox and now the 'Default Language' drop down menu should become populated.
  6. Select your en_US, or whatever your preferred language is.

This is how I solved this problem in Linux Mint Release 18 (Sarah):

  1. Install hunspell package and the dictionaries needed (such as hunspell-en-gb for British English).

  2. In TeXstudio (mine was version 2.10) under Options menu select Configure TeXstudio...

  3. Under Spell Check click the folder button at the right end of Spelling Dictionary Directories

  4. Navigate to the folder where the hunspell dictionaries are installed which in my case was /usr/share/hunspell

  5. Once you navigate to this folder the Directory: text box will still remain empty for some reason. Ignore that and press Choose button to select the current folder

  6. Now on the Configure TeXstudio dialog, select the appropriate dictionary from the Default Language drop-down list and press OK

I had the same problem running TeXStudio on macOS. The issue was fixed by going to "Preferences -> Language Checking" and changing "Spelling Dictionary Directories" to:

/Applications/texstudio.app/Contents/Resources

For some reason the default value was some obscure directory: /private/var/folders/vj/8rqcn3595bn4rxj8tx4nbmxr0000gn/T/AppTranslocation/ACDC786F-24E9-4FF4-B18B-71A724BF1A18/d/texstudio.app/Contents/Resources

  • This! (+1) No need to add dictionaries manually. – epsilone Feb 25 at 12:12

TeXstudio comes with dictionaries; you don't need to install them. I had the same problem. TeXstudio said that no dictionary was available. When I went to choose a dictionary in the options menu, none showed up, yet when I went to the same file in the file explorer, I saw that there were plenty. I noticed that the .dat files had Norton Studio icons. Once I uninstalled Norton Studio and restarted TeXstudio, the dictionaries were there automatically.

  • 2
    It comes with dictionaries for some langages, I had to follow the Peter Jansson's instructions. – Antoine May 6 '15 at 17:19

In the native preferences after installation on my ubuntu here I saw that the dictionaries were located in a folder called "hunspell". Under linux you could install some additional with

sudo apt-get install hunspell-*

with * being one of your preferred dictionaries. May be an easier procedure.

I had some problem because the dictionary I downloaded only had .aff and .dic, but no .dat nor .idx. It happens that .aff and .dic are hunspell files which I had already installed. I remember I checked for my language on hunspell but there was no support available. So, just to resume, I copied the files to /usr/share/hunspell/. Then I opened TexStudio and went to Options -> Configure TexStudio -> General and set my lang there. Now it works.

Hunspell is a spell checker and morphological analyzer designed for languages with rich morphology and complex word compounding and character encoding, originally designed for the Hungarian language. Texstudio, TexWorks, OpenOffice, LibreOffice, FireFox and other programs use it (source: Wikipedia).

As written elsewhere for this question, if needed, you can download the .oxt package at OpenOffice website or LibreOffice's. There are many languages available. As you unpack it, 2 main files should show up: .dic and .aff. These 2 files should be moved to an appropriate folder, indicated at TexStudio preferences. The program will automatically look for dictionaries at this folder.

If the language you wish to use is not available to be used by TexStudio, you might be experiencing one, or more, of the following situations:

  1. The dictionary's files weren't installed along with TexStudio, or another software.

  2. Your system has the files but TexStudio is not pointing to the right folder.

  3. The files are where they should be and TexStudio has the right path, however, it's not being seen, like if they weren't there. If you are using a Unix-like system (Linux or Mac), these files should have at least "read" permission for your kind of user, otherwise they will not be accessible by TexStudio. If you are using Mac, get the folder's information and verify it's permission status at the bottom of the info box. If you are using Linux, check out more informations about "permissions" at:

    http://www.computerhope.com/unix/uchmod.htm

    http://linuxcommand.org/lts0070.php

    For Ubuntu, and maybe other Linux distribution, check out the Hunspell's folder at /usr/share/hunspell.

    For Mac, check out /Applications/TexStudio.app/Contents/Resources.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.