5

I searched all of related posts but it seems that there is no solution in this case.

I really wann activate the feature of historical Ligatures of Libertine font e.g:

In Ubuntu system is it possible to do this by whatever compiler (pdflatex, xelatex, lualatex,etc)?

8

run it with xelatex or lualatex:

\documentclass{article}
\usepackage{libertine}
\begin{document}
\Huge
st ct ff ffl fi ffi

\addfontfeature{RawFeature=+hlig}
st ct ff ffl fi ffi

\end{document}

enter image description here

I suppose that it is not possible with pdflatex and the Type 1 version of Libertine

  • it works like charm! Another question, how do I exclude only "st, ct" ligature? – KOF Dec 28 '12 at 11:31
  • there are three possible values liga, dlig & hlig. they can be enabled or disabled by +/-. And there is also a fontspec for setting the deafult TeX ligatures. – user2478 Dec 28 '12 at 11:39
  • I found that the nummber '0' is like 'o' in text mode, and the arabic number in math mode looks quite different than in text mode. How do I figure this out? The font settings: \usepackage[T1]{fontenc}, \usepackage{libertine}, \usepackage[libertine]{newtxmath} – KOF Dec 28 '12 at 11:51
  • 1
    @KOF if you don't want oldstyle figures in the text you should call libertine with the lining option. Check out the manual. – clemens Dec 28 '12 at 11:57
  • @cgnieder thank you so much. It does work. The only flaw with xelatex is that the Arabic numbers in math mode look like CM font. While with pdflatex, the numbers is identical to the libertine font. – KOF Dec 28 '12 at 12:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.