8

I have an external bib where I put a reference to an external URL.

@misc{myreference,
  author = {The Author},
  title = {The Title},
  howpublished = "\url{http://thisismyurl/2010/3/a-long-url-here}",
  year = {year}
}

When I compile, the URL (when displayed in Bibliography) exceeds the bounds of the page (set as customs). The URL is composed by different terms concatenated with - symbol. a-long-url-here can be the following:

abc-abc-abca-abc-ab-abc-abc-abc-a-abcabc-ab-abc-abc/

The bib is inserted in the following manner:

\bibliographystyle{IEEEbib}
\bibliography{bibliog}

Is there any mechanism to fix this behaviour? I checked Line breaking of URLs in bibliographies but I don't know how to use it in my situation.

Edit

For the sake of completeness, I use PdfLatex.

  • Did you try the suggested \sloppy and \emergencystretch settings? – mafp Dec 28 '12 at 18:47
  • @mafp No. Where do I have to put these commands? Thanks. – Lorenzo B Dec 28 '12 at 18:52
  • 4
    since the url package allows breaks, it sounds like you are using hyperref, which doesn't allow them by default. if you specify the option \usepackage[breaklinks]{hyperref} you should get better results. of course, this is just a guess; i'm not familiar with the IEEEbib style, so it may apply some restrictions i'm not aware of. – barbara beeton Dec 28 '12 at 18:58
  • 3
    To avoid the option clash, you can type \hypersetup{breaklinks=true}. – Mico Dec 28 '12 at 20:51
  • 1
    Don't provide both of these instructions, but only the first one -- after the hyperref package has been loaded either directly by one of your own instructions or indirectly by one of the packages you load (or by the document class). – Mico Dec 30 '12 at 0:15
6

Assuming that you have a file named bibliog.bib with the contents given in your posting, the following MWE (minimum working example) generates a reference with the URL string broken at a hyphen. The key steps are (i) load the url package with the hyphens option and (ii) enable the breaklinks=true option of the hyperref package.

\documentclass{article}
\usepackage[hyphens]{url}
\usepackage{hyperref}
\hypersetup{colorlinks=true,breaklinks=true}
\setlength\textwidth{4in} % simulate a very narrow line width
\begin{document}
\nocite{*}
\bibliographystyle{IEEEtran} % *not* IEEEbib...
\bibliography{bibliog}
\end{document}

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.