How to type these special letters from European languages in latex? ä, é, and L'?

  • try texmaker portable means without installing it Sep 6 '20 at 15:55

You can type texdoc lshort in a command line (Command Prompt on Windows, Terminal on Linux/Mac OS X). Then have a look at Table 2.2 in Section 2.4.8. I'll quote it for you here. alt text

  • 24
    You can also type them directly and use the inputenc package, which makes your source a lot more readable.
    – Alan Munn
    Jan 13 '11 at 3:25
  • Do you know how to type "L'" as well? Thanks. I typed "L'" and "L\'", but both does ways do not display "L'" when it generates the pdf file.
    – user2918
    Jan 13 '11 at 3:28
  • Assuming you typed "\L" and not "L\", if you're still not getting the character its because of the font encoding or the font itself (which may not have the glyph.) It should work with a standard TeX distribution. Did you try my suggestion too?
    – Alan Munn
    Jan 13 '11 at 4:24
  • THe problem with using character modification is that spelling no longer works properly....or maybe there's a way around that too...let me ask a new questions. Jan 13 '11 at 11:57
  • 3
    The "L'" should work with \usepackage[T1]{fontenc} and \v L Jan 13 '11 at 13:00

With pdfLaTeX

Save your file as UTF-8 and put

\usepackage[utf8]{inputenc} % usually not needed (loaded by default)

in your preamble. With current (>2018) distributions inputenc is no longer needed if the file is UTF-8, as that is the assumed default encoding.

Then you can just type the characters normally into your source file.

With XeLaTeX or LuaLaTeX

ALternatively you can use XeLaTeX or LuaLaTeX which accept UTF-8 input natively. In that case you need to add only:


to your preamble. You should not load inputenc (or fontenc) in this case. These engines allow you to use any font installed on your system. See the fontspec documentation for more details.

Lousy editor

If your text editor doesn't support UTF-8 encoded files, you should probably get another editor. But if you're stuck with one, you can also use:

\usepackage[latin1]{inputenc} % for PCs
\usepackage[applemac]{inputenc} % for Macs

and save the files in the default encoding for your machine. You cannot use XeLaTeX or LuaLaTeX with such files, however.

  • 4
    Good advice. It's a good idea to load lmodern after switching the font encoding so that you get a font with all the extra accents and letters in it. Jan 13 '11 at 7:29
  • 1
    Big upvote for fontspec. I was using lualatex and Unicode characters were not displayed at all. I tried inputenc, fontenc, lmodern, babel, polski and nothing worked.
    – user31389
    May 13 '15 at 14:53
  • 1
    I'm all for UTF-8, but how would you suggest handling scenarios where the publisher's (archaic) template (I'm looking at you, IEEE) doesn't include the necessary packages? Would you simply add them to the template? Jan 31 '16 at 10:46
  • 2
    @DaveEveritt If the publisher accepts LaTeX source documents then you should definitely not change the engine, so using LuaLaTeX or XeLaTeX instead of pdfLaTeX is almost certainly not an option. But loading inputenc and fontenc is likely to be ok. If the publisher provides a style file but you submit camera ready PDF based on the style, then using any engine you like should be fine, and therefore loading the packages you need.
    – Alan Munn
    Jan 31 '16 at 14:52
  • 1
    @AlanMunn thanks, that's well-put. I suppose the only remaining issue is to make sure the result doesn't stray from the publisher's fonts. Jan 31 '16 at 15:15

Users looking to make common accents in regular text mode can do so with, for example, \'e.


Alfred Land\'e.


enter image description here

  • 5
    I think Kit already covered this in their answer from five years ago, no?
    – Au101
    Apr 13 '16 at 16:23
  • 1
    This answer is a surely duplicate, as already noted by Au101. I flagged it for deletion. Jan 9 '17 at 9:20
  • 3
    @HenriMenke, I'm sorry you feel that way; I think this answer much more clearly answers the question than Kit's answer. In face, I remember seeing this thread during my research and having to continue looking for the answer because it seems "buried" above. Jan 9 '17 at 13:42
  • 1
    This answer is very helpful--definitely not a duplicate. Kit's answer doesn't show how to produce a grave or acute accent using characters on a standard US keyboard layout. This shows that an acute accent can be produced with a normal apostrophe (U+0027), but Kit's answer shows a right single quotation mark (U+2019).
    – lehiester
    Mar 6 '18 at 21:26

You can use Detexify. Just draw your symbol, and it will figure out what you need to type! Much easier than plowing through endless symbol tables :).

  • 1
    I tried and I couldn't make it work for any accented letter, although it works for a lot of usual mathematical signs.
    – Pere
    Jan 14 '18 at 9:41

The package selinput was not yet mentioned. Because I found good answers regarding its use on other places in TeX.SX let me first link to them:

The hardest part can be to find out, what has actually to be written in \SelectInputMappings, read the package documentation for this. You are not forced to add every letter not in ASCII range, but you have to add some distinctive characters for your language. Below I added the letters from question.



I don't mind plowing my way through symbol lists. Once I've found what I need, and then use it nth of times, I don't forget it. It's a good learning process.



Maybe a short hint for the German users: If you want to get an é (e accent acute) as described in this answer, you have to pay attention to not write \´e as you are possibly used to do in e.g. a text-based program like Microsoft Word. That "locking in and waiting for input" behavior of the accent keys is called diacritic btw - US users can switch their keyboard to US International to get a feel. (´ is the accent key between ß and BACKSPACE on a geraman layout)

You should write \'e instead (' is the apostrophe key, SHIFT + #).

For reference I marked the correct key in green and the incorrect in yellow: Apostrophe (correct) vs accent (wrong)

This could also apply for all keyboards with the dedicated accent keys, probably also french, spanish, italian or more (requires more research).

It does not apply for the standard US-one as there is a dedicated key for ~ = SHIFT + `.

  • This is really out-of-date advice. The default file encoding assumed by the LaTeX kernel is UTF-8, as is the default file encoding of most editors. So the simple answer is just type your letters as you would in any other application, and make sure you're loading a font that contains them.
    – Alan Munn
    Sep 6 '20 at 16:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.