After having answered this question I thought "hmm, maybe I should actually install that package and see if it's as good as it looks...

So I tried. I downloaded ccicons.tds.zip from here and unzipped it into my ~/texmf

this is a procedure that has worked for me before with siunitx and a couple of other packages, so I thought there'd be no problems here.

But when I try and use the package, I got an error. So I went and had a look at the readme, and it told me to run updmap --enable Map ccicons.map so I did. But I still get an error:

kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 1+0/600 --dpi 600 cciconsmktexpk: don't know how to create bitmap font for ccicons.
kpathsea: Appending font creation commands to missfont.log.
!pdfTeX error: pdflatex (file ccicons): Font ccicons at 600 not found
 ==> Fatal error occurred, no output PDF file produced!

LaTeX exited abnormally with code 70 at Thu Jan 13 17:39:09

I don't know how to fix this.

If I compile to DVI rather than straight to PDF (that is, if I use auctex's LaTeX mode rather than the PDFLaTeX mode) I can compile the document, but the \ccLogo appears as a capital gamma... Also, when I compile to pdf, it says LaTeX successfully formatted [0] pages but the log file contains the error above.

I'm on Ubuntu 10.10 using the package manager version of TeXlive.

I have similar issues with certain of the TeX gyre fonts installed through the package manager: tgpagella and tgtermes for instance. I get more or less the same behaviour: compiles 0 pages in PDFLaTeX mode, logs an error about font not found (again mentioning "at 600" whatever that means), but I can compile to dvi fine...

I've run just about every version of updmap I can imagine, and since the issue also occurs with fonts installed through the ubuntu package manager, I don't think the issue has to do with that.

Complete log available here (with listfiles)

  • @Hendrik Thanks, but as far as I can tell, I do have the fonts in the right place... (either that, or there is something subtly wrong with the ccicons.tds.zip on CTAN...)
    – Seamus
    Jan 16, 2011 at 14:04
  • It's a pity that it didn't help, but from the beginning I wasn't sure at all, so I wrote "Related". Jan 16, 2011 at 14:07
  • I don't have much idea about fonts, but TeXLive knows and seems to be able to install ccicons from its package manager. (Actually, it was already installed on my system.) Have you tried to use tlmgr to do the install? Jan 17, 2011 at 11:56
  • @Juan The Ubuntu version of TeXlive doesn't have tlmgr, I don't think. It's weird...
    – Seamus
    Jan 17, 2011 at 13:35

2 Answers 2



updmap-sys --enable Map=ccicons.map

to make the font known to your system. If your TeX distribution was installed as root, then use sudo. If you had it run before always as updmap (without -sys) then you only have a local pdftex.map in your home directory. You shouldn't mix updmap and updmap-sys runs, when you are a user and administrator on the computer. In this case use always updmap-sys or sudo updmap-sys. It may be nessesary that you have to delete the local copy of pdftex.map if you are in trouble.

my testdoc:




  • @Herbert I did this and I get the same error.
    – Seamus
    Jan 13, 2011 at 18:14
  • @Seamus: can you run my test doc please
    – user2478
    Jan 13, 2011 at 18:28
  • @Herbert same error.
    – Seamus
    Jan 14, 2011 at 11:19
  • @Seamus: if you run updmap-sys --edit Is the ccicons.map listed?
    – user2478
    Jan 14, 2011 at 15:48
  • @Herbert updmap.cfg does include a line ccicons.map
    – Seamus
    Jan 14, 2011 at 17:14

On Windows 7, running MiKTeX 2.9, I just updated the fonts, by running (as an Admin), the "Update" module (under the "Maintenance (Admin)" folder), and then selecting all possible updates.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.