After a recent upgrade of ConTeXt, ConTeXt can not longer find the OTF and TTF fonts in my ~/.fonts directory.

Prior to this upgrade, when I ran these three script, it was sufficient to get the fonts working:

rm -R ~/.context
mkdir ~/.context
cd ~/.context
wget http://minimals.contextgarden.net/setup/first-setup.sh
chmod +x first-setup.sh
context --generate
export OSFONTDIR="$HOME/.fonts"
mtxrun --script fonts --reload

This time, when running this, mtxrun --script fonts --reload displays this message:

fonts | names | identifying system font files with suffix otf fonts | names | adding path from OSFONTDIR: /home/username/.fonts fonts | names | globbing path /home/username/.fonts/**.otftexlua: ../../../source/texk/kpathsea/cnf.c:255: kpathsea_cnf_get: Assertion `kpse->program_name' failed. Aborted

When I run mtxrun --script fonts --list -all --pattern=*, ConTeXt no longer reports finding any of my fonts in ~/.fonts. Also, when I try to compile documents, they can no longer use the fonts in ~/.fonts and my documents are all compiled with ConTeXt's default fonts.

I first encountered this problem with 2012.12.28 and still with 2013.01.02 and 2013.01.10 it is present. Prior to this upgrade, I was using a version from October or November 2012.

Why do my custom OTF and TTF fonts no longer work after upgrading ConTeXt?

closed as too localized by Aditya, Martin Schröder, diabonas, Thorsten, Stefan Kottwitz Jan 20 '13 at 20:05

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • The ~/.fonts is searched by default. What happens if you do not set OSFONTDIR – user2478 Jan 3 '13 at 7:23
  • 1
    Which distribution are you using? – Aditya Jan 3 '13 at 7:27
  • If I do not set OSFONTDIR, mtxrun --script fonts --reload finishes very quickly with no apparent errors, however, it makes no mention of adding the fonts from ~/.fonts and furthermore does not add the fonts to ConTeXt. I am using Debian, but installed ConTeXt from ./first-setup.sh with no options added. – Village Jan 3 '13 at 7:47
  • 1
    Can you try with todays beta 2013.01.09 10:51? It works here. – Marco Jan 9 '13 at 13:11
  • 2
    type context tells you which binary is being invoked. If it's the correct one, it might be a bug in a font or a bug in ConTeXt/LuaTex handling that particular font. First try to identify the font causing the problems. If the font is working correctly with other programs provide the font name, foundry and used version so we can test it. If it turns out to be a bug in ConTeXt or LuaTeX it might make sense to approach the LuaTeX or ConTeXt mailing list. – Marco Jan 11 '13 at 14:54