I had been using bibtex and then biblatex for quite some time. For the newest edition of my book I moved to biber. I happened t notice that firstnames are sometimes generated and sometimes not. Has this been observed by others?

I have tried to make a minimal example but without success. Using the following code, which shows all the commands related to biblatex I have in my preamble I could not get the firstnames to be shown. Even with the stylefile I made for this book (second line) the error did not occur.

I have a dropbox with the latex files for the book available. I can give access to these.

What do you propose?




\renewbibmacro{in:}{%       Herbert Voss auf http://tex.stackexchange.com/questions/10682/suppress-in-biblatex

%  \setunit{\addspace}%

%  \setunit{\addcolon\space}%


  • Welcome to TeX.sx! No ned to add greetings in your Q/A, use upvoting of answers instead. Jan 10, 2013 at 19:20
  • I came across the same problem; actually, had two authors that suddenly got first names or initials in the citations. In case of one of them, the same author was once showing up in the bib database with middle initial and once without. In a second example there was no such ambiguity, but using the uniquename=false and uniquelist=false options at the end of the option list of biblatex did help. Dec 19, 2013 at 11:27
  • See also tex.stackexchange.com/q/134535/35864
    – moewe
    Jul 2, 2015 at 6:22

3 Answers 3


This is almost certainly to do with using the uniquename and uniquelist options which are enabled by default in most bundled styles. These options mean that biber automatically disambiguates names by using initials or full names, depending on which other names are cited. See the biblatex manual which explains this with some comprehensive examples. If you set uniquename=false and uniquelist=false I'll warrant that the "strange" behaviour you see stops.

  • Unfortunately adding the two options to the optionlist of biblatex did not change the behaviour. Seems to be something else. I have only two citations with J M Conlon and no other Conlon in the entire reference list as first author.
    – bkleine
    Jan 10, 2013 at 19:38
  • 2
    @user24249 We can't really tell what's going on without a minimal example including some sample bib entries. At this point I'd guess it's a combination of the option settings PLK already mentioned and author list formatting in your bib file.
    – Audrey
    Jan 10, 2013 at 20:18
  • 1
    We'll need a minimal example showing the problem. What do you want to happen? Do you always want to see first names and where? In citations?
    – PLK
    Jan 10, 2013 at 22:33
  • I will come back to you when I have found a way to extract an minimal example. As I have shown above I have added all biblatex related information into the ME but did not find the error.
    – bkleine
    Jan 13, 2013 at 18:21

Most often this problem is caused by inconsistent author names in the bib file. For example, if the bib file contains some entries with

author = {Smith, John}

and other entries with

author = {Smith, J}

then biblatex will try to disambiguate these authors, by referring to either J Smith or John Smith.

One way to fix this is to turn off disambiguation, as suggested by @PLK. Another way is to make sure all your bib-entries have consistent names.


Simpler answer: either

  1. include uniquenames=false in the options for biblatex, or
  2. ensure that the author (if it's truly just one person) for whom you notice this problem always has their name written the same way in your .bib files.

For some reason, in several places it is advised to also set uniquelist=false, but setting uniquenames may be sufficient for you (as in this answer: biblatex, authoryear style: In-text citations display first name initials for certain bibliography entries).

By the way, in LyX, you would set uniquename=false in the Document Settings dialog, under "Bibliography", in the first Options box at the top after selecting a Biblatex Style format.

In LaTeX, you would use instead:


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.