I am getting an error when I run memoir with the tikz package. I updated my TexLive distribution to the 2012 version so there should be no conflicting version problems. Memoir and tikz are both in my 2012 texlive path but the log file shows some odd dates. I pared everything down to the simplest example I could make and the error still remains. I am running TexShop on OS X and have tried typesetting both as Pdflatex and Tex+DVI.

Here's the minimum working example. If I comment out \usepackage{tikz} it works fine if I leave it in it spots out an error (listed below). The log file, due to its length, can be found here.







The error I get is this:

! Extra \endcsname.
\@namelet ...fter \endcsname \csname #2\endcsname 


Any assistance would be greatly appreciated as I am attempting to write some lecture notes up for a class that begins soon. Thanks!

  • I get no problems with your code but in the log file I see that you are using babel and maybe other things. So the best would be deleting the aux file and trying again. If you include \listfiles in your preamble it will show you the version info of each package. I have xcolor 2.11 and PGF/TikZ 2.10. – percusse Jan 11 '13 at 18:43
  • I just trashed my aux files and am still getting the error. Potentially dumb question: does the version info show up in the log? Because adding \listfiles didn't seem to change anything in any of the output. – Ian Durham Jan 11 '13 at 18:49
  • Indeed the version infos show up in the log file. – percusse Jan 11 '13 at 18:55
  • Hmm. Well, they did regardless of whether or not I included \listfiles in my preamble. At any rate, the output in the log file looks exactly the same. PGF is 2.10. For whatever reason it's not showing a version for xcolor. Incidentally, before doing all this, I had reinstalled xcolor last night in an effort to solve the problem (before updating my entire TexLive distribution in pure frustration). – Ian Durham Jan 11 '13 at 19:07
  • If you simply go past all of the errors, do you get a file list in the .log? If so, can you edit it in. – Joseph Wright Jan 11 '13 at 19:12