I've been using Texmaker on Ubuntu 12.04 for a while now. I've editing several documents and especially resumes. However, I've recently been experiencing several problems with LaTex and Texmaker, starting from the upgrade to Ubuntu 12.10.

Every time I try to run the file, I have the same error message :

! LaTeX Error: File `roman.sty' not found.
Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: sty)
Enter file name:
! Emergency stop.
<read *>
l.3 \moderncvtheme[grey,roman]{classic}
*** (cannot \read from terminal in nonstop modes)
Here is how much of TeX's memory you used:
3985 strings out of 493485
55137 string characters out of 3143526
154265 words of memory out of 3000000
7282 multiletter control sequences out of 15000+200000
4403 words of font info for 15 fonts, out of 3000000 for 9000
957 hyphenation exceptions out of 8191
42i,0n,53p,787b,152s stack positions out of 5000i,500n,10000p,200000b,50000s
! ==> Fatal error occurred, no output PDF file produced!

This problem really just started when I upgraded Ubuntu from 12.04 to 12.10. During the installation process, I've been notified about "some packages" removal but I don't know which ones. I've tried to remove all the .tex files and packages I have and performed a new installation. The problem is still the same.

Here is a relevant part of my LaTeX document for where it errors out on:



I've also asked this question on Tex.se


It appears that you're using a non-existent option roman to the classic theme of moderncv here:


Unfortunately, the homepage of moderncv at CTAN does not provide any real documentation. The only piece available about it is in the example template file. It is not mentioned as a valid option in there.

In Ubuntu 12.04 there was also no roman.sty file available, so that makes me believe you might have had a local roman.sty file in the local directory some earlier time. While 12.10 upgraded TeXLive from the 2009 version to 2012, I really believe this is not the root cause for your issue.

I also believe you should ask this on Tex.SE for the specific use of this LaTeX package.

  • Hello, Thanks a lot for the help. Since the same code was working properly before I upgraded (didn't do any changes meanwhile; that's actually what I wanted to do when I had this trouble) to 12.10, I can't really explain what went wrong. I'll check on Tex.se Thanks again for everything :-) – Marius Jan 12 '13 at 15:21
  • @Marius, did you find a solution? If so, could you post it here for people like me who are encountering the same problem. Thanks! – ChrisR Mar 21 '13 at 7:46
  • @ChrisR, no not really. I just followed the instructions given by gertvdijk after reinstalling TexMaker and my LaTex packages (not that I needed to but just to be sure). I don't have that problem anymore but I can't really tell you how it got solved! Sorry I can't be more helpful :-( – Marius Mar 21 '13 at 11:20

I came across the same problem. My cv compiled fine on Ubuntu 12.04 and failed to compile on Ubuntu 14.04. I was loath to mess around with my Tex installation. Looking at the sample file provided at /usr/share/doc/texlive-doc/latex/moderncv/examples/template.tex.gz gave me a hint. I changed my cv file slightly and I could compile. Here is the diff:

diff -r1.3 noricv.tex
> % new template comes from /usr/share/doc/texlive-doc/latex/moderncv/examples/template.tex.gz
< \moderncvtheme[green,roman]{classic}                % idem
> %\moderncvtheme[green,roman]{classic}                % idem
> \moderncvstyle{classic}                             % style options are 'casual' (default), 'classic', 'oldst
> \moderncvcolor{green}                               % color options 'blue' (default), 'orange', 'green', 'red

So just replace \moderncvtheme with \moderncvstyle and \moderncvcolor.


I am happy to find and share a very simple workaround. I downloaded all the .sty files and moderncv.cls file from the following link:


And kept all those files in the directory where my cv.tex file is kept.

Amazingly, compiling with pdflatex this time produced my cv.pdf with NO ERRORS :)

I hope it will work for others as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.