While LaTeX-based PDFs are generally very good when printed, I find most of them really hard and annoying to read on-screen when viewing the full page. Most line widths are very small, which results in badly rendered screen fonts or e.g. boxes with some non-displayed lines. Documents produced with other software don't suffer so much from this.

For example:

  • try reading this letter on screen in a PDF reader such as Adobe Reader.
  • or see the box in this document on page 2, at certain zoom levels the left line of the box is not shown)

Besides zooming in in the PDF reader (I don't like that, because I loose overview), or changing the default Latex font, is there an easy way to make LaTeX PDFs more on-screen readable?

(PS: I use Windows)

  • 4
    Letter 1's problems stem (primarily) from being converted to PDF a long time ago. Are you having that kind of problem with your documents?
    – Ken Bloom
    Commented Jan 20, 2011 at 15:56
  • 1
    On a related note, for people using Acrobat as their PDF viewer, I've just discovered an Acrobat (8) setting that improved my PDF viewing experience of LaTeX documents considerably: Edit > Preferences > Page Display > Smooth Text > 'For Laptop/LCS screens' is much better than the default 'For Monitor'. The default LaTeX font at small scale is now much better readable on screen. Commented May 23, 2012 at 9:57

3 Answers 3


The first document has no scalable fonts, it uses the default ComputerModern. A


will help. And for the second document it is always a problem with the viewer and the magnification.

  • 3
    'And for the second document it is always a problem with the viewer and the magnification.' Hmm, I was afraid of these kind of answers... Commented Jan 20, 2011 at 11:27
  • 1
    Most modern setups should be able to give you a nice scalable Type 1 Computer Modern with hinting (no need to change the font), but if you're having problems you can look at a couple of questions in the TUG FAQ that discuss this issue, and mostly relate to older TeX installations.
    – Ken Bloom
    Commented Jan 20, 2011 at 16:13
  • 1
    it is not a question of the setup. Installing the CM super is more than 50 megabytes of code, the reason why they are not installed by MiKTeX by default. But using the lmodern package solves the problem and it has some corrections to the original CM
    – user2478
    Commented Jan 20, 2011 at 16:17
  • 1
    @Herbert, there is no need for lmodern or cm-super (as @Ken said) so long as one uses OT1 (as I am sure is the case for Knuth's letter). All Knuth needs to do to improve the fonts is to re-TeX his letter from it's unchanged original source but with a modern distribution so that it automatically picks up the type-1 CM fonts instead of the metafont-generated type-3. This will even look better than your suggestion to use lmodern, because the bluesky CM are much better hinted than lmodern.
    – Lev Bishop
    Commented Jan 20, 2011 at 16:35
  • 2
    @Herbert: Hinting problems with latin modern: see i.imgur.com/WNzem.png CM on the top, lmodern on the bottom. Note: 1) uneven tops of the capitals on lines 1 and 3; 2) heavy curves on the r, m & n on line 2; 3) very heavy W on line 3; 4) lower right corner of d on line 4. Other problems occur at different zoom levels.
    – Lev Bishop
    Commented Jan 20, 2011 at 18:38

You could always try increasing the font size and the weight of the lines in order to have them display better at lower magnifications. Also, use a font that looks better onscreen than does CM.


for example.

  • 2
    That's a really nice font (and indeed more readable than CM). Funny how the wikipedia entry says for bitstream-charter: 'Bitstream Charter is a typeface optimized for printing on the low-resolution 300 dpi laser printers of the 1980s.'. It seems it is indeed intended for low-resolution output devices (screen 72-92 dpi) Commented Jan 20, 2011 at 13:35
  • there are tons of possible fonts, e.g. \usepackage{kpfonts} with a complete set of math symbols.
    – user2478
    Commented Jan 20, 2011 at 14:57

For the second example, if you are using Adobe Reader, try going to preferences and turning off "Enhance thin lines" and turning on "Smooth line art" in the "Page Display" category (under the "Rendering" heading).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .