I am using biblatex and biber. Here is a sample LaTeX file.


  references = {Selected Publications}, 

Ref.~\cite{CJS:2013} and~\cite{BCW:2012}.


The reference BCW:2012 looks like this in the bib file.

  author    = {B and
               C and
  title     = {Musings and machinations},
  eprinttype   = {arXiv},
  eprint    = {1234.5678},
  eprintclass = {cs.DS},
  year      = {2012}

The problem is that the title "Musings and machinations" doesn't have quotes round it when rendered whereas all other (non-arXiv) papers do. What am I doing wrong?

I am using biber version 0.9.9.

  • Could you elaborate a bit on 'non-arXiv papers'? Are they also of type online or are they article-type? – Joseph Wright Jan 15 '13 at 19:46
  • @JosephWright This is the only online paper. The rest are of type article and InProceedings. – Raphael Jan 15 '13 at 19:47

The standard biblatex settings include the lines


thus meaning that the title field is not put in quotes for online entries. This can be altered uing

  • Thank you! Is this documented somewhere or just in the source? – Raphael Jan 15 '13 at 20:09
  • This is in the source. There are simply too many fields/formats to document everything formally: the idea is that the mechanisms to change formatting are documented, so you can rapidly alter things to what you want. – Joseph Wright Jan 15 '13 at 20:12
  • OK. Well I don't see how I could have solved my particular problem without either reading the source or asking here. Is there a way I am missing? – Raphael Jan 15 '13 at 20:26
  • 1
    @Raphael \DeclareFieldFormat is described in the manual, as are \mkbibquote and \isdot. Reading biblatex.def is useful for style changes: it's commented and I think reasonably clear. – Joseph Wright Jan 15 '13 at 20:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.