70

I would like to start each section on a new page. Is adding the following to my preamble this the preferred method, or a hack?

\let\stdsection\section
\renewcommand\section{\newpage\stdsection}
  • 2
    Perhaps you would like to use \clearpage instead of \newpage if you use floats. – Stefan Kottwitz Jan 22 '11 at 22:11
  • 1
    Why not use a document class that allows chapters, and use them instead (since they automatically start on new page..) – Seamus Jan 22 '11 at 22:34
  • @Stefan you are correct, although my present document is not using floats. – David LeBauer Jan 22 '11 at 22:38
  • 2
    Alternatively, just find and replace all \section{ with \clearpage\section{ – Seamus Jan 22 '11 at 22:41
  • 1
    @Seamus I'd like to use this in emacs org-mode, so it is more straightforward to place this in the preamble – David LeBauer Jan 22 '11 at 22:44
87

The titlesec package allows to do this with just

\newcommand{\sectionbreak}{\clearpage}

It's cleaner than what you were doing and the package also allows to completely customize sections. Here's a fully compilable code sample showing how it works:

\documentclass{article}

\usepackage{titlesec}
\newcommand{\sectionbreak}{\clearpage}

\begin{document}

Text

\section{Title}
Text
\subsection{Title}
Text
\subsection{Title}
Text

\section{Title}
Text

\end{document}
  • 10
    note: if you have a \subsection without content, the \section after it won't be pushed to a new page. I don't know whether this is a bug, expected, or irrelevant, but I thought it's worth mentioning it as first I was a bit puzzled why the \clearpage solution didn't work. – Karoly Horvath Jul 26 '13 at 17:43
  • 3
    @KarolyHorvath: if you look up the code for \ttl@straight@ii in titlesec.sty, you clearly see the explanation for this phenomenon: the \sectionbreak command is only used if the boolean @nobreak is false, which is not the case just after a subsection title (but is once some text has been typesetted). One could easily patch \ttl@straight@ii to behave as you want, but it's probably simpler to use the solution from tex.stackexchange.com/q/47047 – Philippe Goutet Jul 26 '13 at 19:11
  • 2
    @Kaspar: yes, that's what \clearpage does (it clears all figures then makes a page break). Try using another pagebreaking command like \pagebreak if you don't want this. – Philippe Goutet Apr 27 '16 at 4:55
  • 1
    This solution causes problems when the document includes a ToC and hyperref support: It makes the paging of the hyperref links be off-sync with the document paging (e.g. clicking on Section 3 which is on p4 will take you to p3 instead). In this sense, the hack in the original question is the better approach... – landroni Nov 7 '16 at 20:36
  • 3
    @landroni: no, it works perfectly. You're probably loading hyperref before titlesec, which is why it doesn't work (there are a few exceptions, but generally speaking, hyperref should be the last package you load). Alternatively, you can make if work with hyperref loaded first by using \newcommand{\sectionbreak}{\clearpage\phantomsection}. – Philippe Goutet Nov 9 '16 at 6:45
10

Obligatory ConTeXt solution:

\setuphead[section][page=yes] % or page=right
  • 1
    This mysterious answer seems to have more than what meet the eyes. Care to elaborate? Thanks. – Dr Beco Sep 25 '18 at 4:41
  • @DrBeco: ConTeXt is a macro package built on TeX (just as LaTeX is a macro package built on TeX). ConTeXt has a much more consistent user interface and many questions that arise in LaTeX have a simple solution in ConTeXt. I am one of the few ConTeXt users on this site. And when I wrote this answer, I was proving ConTeXt solution to various LaTeX questions. – Aditya Sep 25 '18 at 7:13
  • If tex4ht would work with context, I would try context. But from what I understand tex4ht only works with latex. This is a major limitation to many who want to convert latex to HTML as well to pdf. – Nasser May 17 at 4:30
  • ConTeXt supports XHTML and XML export out of the box: wiki.contextgarden.net/Export – Aditya May 17 at 20:43
5

The accepted answer in that form won't work as expected in LyX. This solution causes problems when the document includes a ToC and hyperref support: It makes the paging of the hyperref links be off-sync with the document paging (e.g. clicking on Section 3 which is on p4 will take you to p3 instead).

As mentioned in the comments, this happens because by default LyX is loading hyperref before titlesec. To work around this you can use \newcommand{\sectionbreak}{\clearpage\phantomsection}.

Alternatively, in LyX, you can include in Document Settings > Local Layout:

Provides hyperref

And then load hyperref manually in the LaTeX preamble, like this:

\usepackage{titlesec}
\newcommand{\sectionbreak}{\clearpage}
\usepackage{hyperref}
5

Another solution, which uses the sectsty package:

\usepackage{sectsty}
\sectionfont{\clearpage}
3

An alternative solution is to enclose each section in an \include, because \include does an automatic \clearpage before. No preamble necessary!

  • 5
    Welcome to TeX.SX! While this works, it may require quite a substantial change to the set-up of the document. – Andrew Swann Nov 13 '14 at 10:01
1

I would rather use what Philippe Goutet has already mentioned.

\usepackage{titlesec}
\newcommand{\sectionbreak}{\clearpage}

These are very convenient and save you the effort of typing \clearpage at the end of each section. Needless to mentioned that you can apply the same to \subsection and \subsubsection. You can also manage the spacing between the section title and the first paragraph.

Perhaps you should take a look at the documentation if you're interested.

  • Would you add this information to the answer above? When answers don't add new information, they may be downvoted on this site. – Yaroslav Nikitenko Sep 6 '18 at 16:07
  • So should I delete my answer? – Kareem Jeiroudi Sep 7 '18 at 19:16
  • Yes, I think that the basis of your question doesn't add anything. If there is something new, you can add that as an edit. Brevity is good, few answers (if new answers don't add information) are good for stackexchange. – Yaroslav Nikitenko Sep 9 '18 at 12:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.